aboutsummaryrefslogtreecommitdiffstats
path: root/common/rfb/CMakeLists.txt
diff options
context:
space:
mode:
authorCarlos Santos <casantos@redhat.com>2023-11-28 18:11:13 -0300
committerCarlos Santos <casantos@redhat.com>2024-04-23 17:41:01 -0300
commitae81801cccbbef7c424103ec3aee9bfc6021059e (patch)
treeb9d288bf7e8341cad9b54c7f240f84e08bf16e65 /common/rfb/CMakeLists.txt
parent34d96928632b79196cc3d46aa2abd7c1f1122593 (diff)
downloadtigervnc-ae81801cccbbef7c424103ec3aee9bfc6021059e.tar.gz
tigervnc-ae81801cccbbef7c424103ec3aee9bfc6021059e.zip
Move the AccessRights type and constants to the rfb namespace
They must belong to the rfb namespace, not to the SConnection class. Also add an AccessNone constant, since it's better to use a mnemonic symbol rather than zero to initialize the accessRights members. Signed-off-by: Carlos Santos <casantos@redhat.com>
Diffstat (limited to 'common/rfb/CMakeLists.txt')
-rw-r--r--common/rfb/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/common/rfb/CMakeLists.txt b/common/rfb/CMakeLists.txt
index 2cae2356..360434a9 100644
--- a/common/rfb/CMakeLists.txt
+++ b/common/rfb/CMakeLists.txt
@@ -1,4 +1,5 @@
add_library(rfb STATIC
+ AccessRights.cxx
Blacklist.cxx
Congestion.cxx
CConnection.cxx