aboutsummaryrefslogtreecommitdiffstats
path: root/common/rfb/Makefile.am
diff options
context:
space:
mode:
authorAdam Tkac <atkac@redhat.com>2010-04-23 14:06:38 +0000
committerAdam Tkac <atkac@redhat.com>2010-04-23 14:06:38 +0000
commit1d15e2d60a171a43c83e51a1343727701ac34f4b (patch)
tree01eebc9a1baf00ade1c7fe2495c16cd3abc08113 /common/rfb/Makefile.am
parentb6eb3990a15e32e7d506ef713da51ca0305ef4a9 (diff)
downloadtigervnc-1d15e2d60a171a43c83e51a1343727701ac34f4b.tar.gz
tigervnc-1d15e2d60a171a43c83e51a1343727701ac34f4b.zip
[Development] Implement Security class. This class will be used to create
CSecurity/SSecurity objects for authentication purposes. git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4038 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'common/rfb/Makefile.am')
-rw-r--r--common/rfb/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/common/rfb/Makefile.am b/common/rfb/Makefile.am
index 93189b99..a3b134fc 100644
--- a/common/rfb/Makefile.am
+++ b/common/rfb/Makefile.am
@@ -13,9 +13,9 @@ HDRS = Blacklist.h CapsContainer.h CapsList.h CConnection.h \
PixelFormat.h PixelFormat.inl Pixel.h RawDecoder.h RawEncoder.h \
Rect.h Region.h rreDecode.h RREDecoder.h rreEncode.h RREEncoder.h \
ScaledPixelBuffer.h ScaleFilters.h SConnection.h ScreenSet.h \
- screenTypes.h SDesktop.h Security.h ServerCore.h SMsgHandler.h \
+ screenTypes.h SDesktop.h ServerCore.h SMsgHandler.h \
SMsgReader.h SMsgReaderV3.h SMsgWriter.h SMsgWriterV3.h \
- SSecurityFactoryStandard.h SSecurity.h SSecurityNone.h \
+ Security.h SSecurityFactoryStandard.h SSecurityNone.h \
SSecurityVncAuth.h Threading.h tightDecode.h TightDecoder.h \
tightEncode.h TightEncoder.h TightPalette.h Timer.h \
TransImageGetter.h transInitTempl.h transTempl.h TrueColourMap.h \
@@ -34,12 +34,12 @@ librfb_la_SOURCES = $(HDRS) Blacklist.cxx CConnection.cxx CMsgHandler.cxx \
RREEncoder.cxx RREDecoder.cxx RawDecoder.cxx RawEncoder.cxx \
Region.cxx SConnection.cxx SMsgHandler.cxx \
SMsgReader.cxx SMsgReaderV3.cxx SMsgWriter.cxx SMsgWriterV3.cxx \
- ServerCore.cxx SSecurityFactoryStandard.cxx SSecurityVncAuth.cxx \
+ ServerCore.cxx Security.cxx SSecurityFactoryStandard.cxx SSecurityVncAuth.cxx \
ScaledPixelBuffer.cxx ScaleFilters.cxx Timer.cxx TightDecoder.cxx \
TightEncoder.cxx TightPalette.cxx TransImageGetter.cxx \
UpdateTracker.cxx VNCSConnectionST.cxx \
VNCServerST.cxx ZRLEEncoder.cxx ZRLEDecoder.cxx encodings.cxx \
- Security.cxx util.cxx
+ util.cxx
librfb_la_CPPFLAGS = -I$(top_srcdir)/common -I$(top_srcdir)/win
librfb_la_LIBADD =