aboutsummaryrefslogtreecommitdiffstats
path: root/common/rfb/Makefile.am
diff options
context:
space:
mode:
authorAdam Tkac <atkac@redhat.com>2008-06-18 15:29:19 +0000
committerAdam Tkac <atkac@redhat.com>2008-06-18 15:29:19 +0000
commit2bcfb6d2c7a15189feb7745553f71a3352838c45 (patch)
treee501dbc05a0c3745179d0e432841250ae499612e /common/rfb/Makefile.am
parentdefdf85be2a94fbb132e2a045e33caa55da1e06b (diff)
downloadtigervnc-2bcfb6d2c7a15189feb7745553f71a3352838c45.tar.gz
tigervnc-2bcfb6d2c7a15189feb7745553f71a3352838c45.zip
Add headers to Makefile.am-s to fix "make dist" command in common/* subtree
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/branches/1.5-xserver@2591 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'common/rfb/Makefile.am')
-rw-r--r--common/rfb/Makefile.am28
1 files changed, 27 insertions, 1 deletions
diff --git a/common/rfb/Makefile.am b/common/rfb/Makefile.am
index 2f9e72e7..7fff7c8a 100644
--- a/common/rfb/Makefile.am
+++ b/common/rfb/Makefile.am
@@ -1,6 +1,32 @@
noinst_LTLIBRARIES = librfb.la
-librfb_la_SOURCES = Blacklist.cxx CConnection.cxx CMsgHandler.cxx \
+HDRS = Blacklist.h CapsContainer.h CapsList.h CConnection.h CFTMsgReader.h \
+ CFTMsgWriter.h CMsgHandler.h CMsgReader.h CMsgReaderV3.h CMsgWriter.h \
+ CMsgWriterV3.h ColourCube.h ColourMap.h ComparingUpdateTracker.h \
+ Configuration.h ConnParams.h CSecurity.h CSecurityNone.h \
+ CSecurityVncAuth.h Cursor.h Decoder.h DirManager.h d3des.h Encoder.h \
+ encodings.h Exception.h FileInfo.h FileManager.h FileReader.h \
+ FileWriter.h fttypes.h hextileConstants.h hextileDecode.h \
+ HextileDecoder.h hextileEncodeBetter.h hextileEncode.h \
+ HextileEncoder.h Hostname.h HTTPServer.h ImageGetter.h InputHandler.h \
+ IrixCLJpegCompressor.h IrixDMIC_RawToJpeg.h IrixDMJpegCompressor.h \
+ JpegCompressor.h JpegEncoder.h KeyRemapper.h keysymdef.h \
+ ListConnInfo.h Logger_file.h Logger.h Logger_stdio.h LogWriter.h \
+ msgTypes.h Password.h PixelBuffer.h PixelFormat.h Pixel.h \
+ RawDecoder.h RawEncoder.h Rect.h Region.h rreDecode.h RREDecoder.h \
+ rreEncode.h RREEncoder.h ScaledPixelBuffer.h ScaleFilters.h \
+ SConnection.h SDesktop.h secTypes.h ServerCore.h SFileTransfer.h \
+ SFileTransferManager.h SFTMsgReader.h SFTMsgWriter.h SMsgHandler.h \
+ SMsgReader.h SMsgReaderV3.h SMsgWriter.h SMsgWriterV3.h \
+ SSecurityFactoryStandard.h SSecurity.h SSecurityNone.h \
+ SSecurityVncAuth.h Threading.h tightDecode.h TightDecoder.h \
+ tightEncode.h TightEncoder.h TightPalette.h Timer.h TransferQueue.h \
+ TransImageGetter.h transInitTempl.h transTempl.h TrueColourMap.h \
+ UpdateTracker.h UserPasswdGetter.h util.h VNCSConnectionST.h \
+ VNCServer.h VNCServerST.h zrleDecode.h ZRLEDecoder.h zrleEncode.h \
+ ZRLEEncoder.h
+
+librfb_la_SOURCES = $(HDRS) Blacklist.cxx CConnection.cxx CMsgHandler.cxx \
CMsgReader.cxx CMsgReaderV3.cxx CMsgWriter.cxx CMsgWriterV3.cxx \
CSecurityVncAuth.cxx CapsContainer.cxx CapsList.cxx \
ComparingUpdateTracker.cxx Configuration.cxx ConnParams.cxx \