aboutsummaryrefslogtreecommitdiffstats
path: root/common/zlib/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2015-02-03 09:54:49 +0100
committerPierre Ossman <ossman@cendio.se>2015-02-03 09:54:49 +0100
commitcc8c6a296f48552dde4375c5b491225262b4814f (patch)
tree3aa592a2b67137cd60664cda546404f15daa12a1 /common/zlib/CMakeLists.txt
parent27eb55e1975c4f558f6a53d573091e76064cc8e7 (diff)
downloadtigervnc-cc8c6a296f48552dde4375c5b491225262b4814f.tar.gz
tigervnc-cc8c6a296f48552dde4375c5b491225262b4814f.zip
Drop bundled zlib
We're not doing a sufficient job of keeping this updated so list it as an external requirement instead.
Diffstat (limited to 'common/zlib/CMakeLists.txt')
-rw-r--r--common/zlib/CMakeLists.txt22
1 files changed, 0 insertions, 22 deletions
diff --git a/common/zlib/CMakeLists.txt b/common/zlib/CMakeLists.txt
deleted file mode 100644
index 69f1c9f9..00000000
--- a/common/zlib/CMakeLists.txt
+++ /dev/null
@@ -1,22 +0,0 @@
-# It seems like gcc for Win32 doesn't support the visibility attribute,
-# so disable it to make it stop complaining.
-if(WIN32)
- add_definitions(-DNO_VIZ)
-endif()
-
-add_library(zlib STATIC
- adler32.c
- compress.c
- crc32.c
- deflate.c
- gzclose.c
- gzlib.c
- gzread.c
- gzwrite.c
- inflate.c
- infback.c
- inftrees.c
- inffast.c
- trees.c
- uncompr.c
- zutil.c)