aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAdam Tkac <atkac@redhat.com>2011-02-09 15:38:37 +0000
committerAdam Tkac <atkac@redhat.com>2011-02-09 15:38:37 +0000
commitb48642369217f870e8571b27196d165aca61d75a (patch)
treeee867b8a00e736fa9a085c1f515eb88b5fdba3d7 /configure.ac
parent68481c19ebfcaed4526c70dac5c14a27f061262a (diff)
downloadtigervnc-b48642369217f870e8571b27196d165aca61d75a.tar.gz
tigervnc-b48642369217f870e8571b27196d165aca61d75a.zip
[Bugfix] Improve compatibility with ancient GNUTLS implementations even more.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4278 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0c709369..278e47bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,7 +112,9 @@ if test "x$enable_gnutls" = xyes; then
[AC_DEFINE(HAVE_GNUTLS_X509_CRT_PRINT, 1, [Is the gnutls_x509_crt_print() function present? ])
AC_MSG_RESULT(yes)],
AC_MSG_RESULT(no))
-
+ AC_CHECK_TYPES([gnutls_x509_crt_t, gnutls_datum_t,
+ gnutls_pk_algorithm_t, gnutls_sign_algorithm_t],
+ [], [], [#include <gnutls/gnutls.h>])
LIBS=${SAVE_LIBS}
fi
AC_SUBST([GNUTLS_LIBS])