aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Åstrand <astrand@cendio.se>2005-01-23 20:44:20 +0000
committerPeter Åstrand <astrand@cendio.se>2005-01-23 20:44:20 +0000
commit5a15f8cbc39c822c479f4b33600ce04e4ae99f8b (patch)
tree7315498bb0bcd6c0148d23f4659cf0487542f870 /configure.in
parent2dbbd38f8f63594dce29ee4836fadff91392ee59 (diff)
downloadtigervnc-5a15f8cbc39c822c479f4b33600ce04e4ae99f8b.tar.gz
tigervnc-5a15f8cbc39c822c479f4b33600ce04e4ae99f8b.zip
Added translation support for the UNIX implementation, via GNU gettext.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@108 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0656694c..b1872733 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,13 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT(rdr/InStream.h)
+PACKAGE=tightvnc
+VERSION=1.5.0
+AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE")
+AC_DEFINE_UNQUOTED(VERSION, "$VERSION")
+AC_SUBST(PACKAGE)
+AC_SUBST(VERSION)
+
dnl dirty hack to prevent use of -g in CFLAGS and CXXFLAGS
ac_cv_prog_cc_g=no
ac_cv_prog_cxx_g=no
@@ -98,6 +105,8 @@ AC_MSG_RESULT(using int)
SOCKLEN_T_DEFINE='-DVNC_SOCKLEN_T=int')
AC_SUBST(SOCKLEN_T_DEFINE)
+AM_GNU_GETTEXT
+
BOILERPLATE=boilerplate.mk
if (sh -c "make --version" 2>/dev/null | grep GNU 2>&1 >/dev/null); then
@@ -106,7 +115,7 @@ if (sh -c "make --version" 2>/dev/null | grep GNU 2>&1 >/dev/null); then
fi
fi
-AC_OUTPUT(Makefile:Makefile.in:$BOILERPLATE \
+AC_OUTPUT(Makefile:Makefile.in:$BOILERPLATE intl/Makefile po/Makefile.in \
rdr/Makefile:rdr/Makefile.in:$BOILERPLATE \
network/Makefile:network/Makefile.in:$BOILERPLATE \
Xregion/Makefile:Xregion/Makefile.in:$BOILERPLATE \