aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Åstrand <astrand@cendio.se>2004-11-16 13:36:36 +0000
committerPeter Åstrand <astrand@cendio.se>2004-11-16 13:36:36 +0000
commitd29243d521afb3b8b08debbcd0c110fc64ba64c0 (patch)
tree2829b47eb71382be47c3838a8cb3a3b1da6cbf38 /configure.in
parente713b1450bb490712e8bd28ee93a0bccc1bcd7af (diff)
downloadtigervnc-d29243d521afb3b8b08debbcd0c110fc64ba64c0.tar.gz
tigervnc-d29243d521afb3b8b08debbcd0c110fc64ba64c0.zip
Configuring and building jpeg library
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@11 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index cbad4603..0656694c 100644
--- a/configure.in
+++ b/configure.in
@@ -63,6 +63,26 @@ AC_SUBST(ZLIB_DIR)
AC_SUBST(ZLIB_INCLUDE)
AC_SUBST(ZLIB_LIB)
+AC_ARG_WITH(installed-jpeg,
+[ --with-installed-jpeg use the version of jpeg which is installed on the
+ system instead of the one distributed with VNC])
+
+if test "$with_installed_jpeg" = yes; then
+ echo "using installed jpeg"
+ JPEG_LIB=-ljpeg
+else
+ JPEG_DIR=jpeg
+ JPEG_INCLUDE='-I$(top_srcdir)/jpeg'
+ JPEG_LIB='$(top_srcdir)/jpeg/libjpeg.a'
+ echo "configuring jpeg..."
+ (cd jpeg; ./configure)
+ echo "...done configuring jpeg"
+fi
+
+AC_SUBST(JPEG_DIR)
+AC_SUBST(JPEG_INCLUDE)
+AC_SUBST(JPEG_LIB)
+
AC_CHECK_FUNC(vsnprintf,VSNPRINTF_DEFINE='-DHAVE_VSNPRINTF',VSNPRINTF_DEFINE=)
AC_SUBST(VSNPRINTF_DEFINE)