aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/packages/deb/ubuntu-jammy/debian/rules
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2024-02-21 17:07:36 +0100
committerPierre Ossman <ossman@cendio.se>2024-06-20 14:41:48 +0200
commit50048184a08f12cdf66064a5606fee2e981db9e8 (patch)
tree5c57d8a736495ac00ddf1abc5da3e4cf544dbfca /contrib/packages/deb/ubuntu-jammy/debian/rules
parentc30370df0878b823bd520a31567a69763259d5a5 (diff)
downloadtigervnc-50048184a08f12cdf66064a5606fee2e981db9e8.tar.gz
tigervnc-50048184a08f12cdf66064a5606fee2e981db9e8.zip
Add basic DRI3 support
This provides buffer sync with the primary render node of the system (if available). By doing so, OpenGL and Vulkan can use the render node for acceleration. This first implementation is extremely pessimistic and synchronises buffers whenever there's even a slight chance they will be used.
Diffstat (limited to 'contrib/packages/deb/ubuntu-jammy/debian/rules')
-rw-r--r--contrib/packages/deb/ubuntu-jammy/debian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/contrib/packages/deb/ubuntu-jammy/debian/rules b/contrib/packages/deb/ubuntu-jammy/debian/rules
index 02e798c9..1b4fd6f8 100644
--- a/contrib/packages/deb/ubuntu-jammy/debian/rules
+++ b/contrib/packages/deb/ubuntu-jammy/debian/rules
@@ -45,7 +45,7 @@ XORG_SOURCE_ARCHIVE = /usr/src/xorg-server.tar.xz
xorg-source-stamp: $(XORG_SOURCE_ARCHIVE)
tar -C unix/xserver -axf $(XORG_SOURCE_ARCHIVE) --strip-components=1
- cd unix/xserver && patch -p1 < ../xserver21.1.1.patch
+ cd unix/xserver && patch -p1 < ../xserver21.patch
patch -p1 < debian/xorg-source-patches/516_tigervnc-xorg-manpages.patch
touch xorg-source-stamp
@@ -102,7 +102,7 @@ config-stamp: xorg-source-stamp
--enable-xdmcp \
--enable-xdm-auth-1 \
--enable-glx \
- --disable-dri --enable-dri2 --disable-dri3 \
+ --disable-dri --enable-dri2 --enable-dri3 \
--enable-xinerama \
--enable-xf86vidmode \
--enable-xace \