aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/packages/deb/ubuntu-trusty/debian
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2019-01-18 16:46:30 +0100
committerPierre Ossman <ossman@cendio.se>2019-01-21 16:34:33 +0100
commit376f2dda782bc59febc9af32336e7c6ebbf5c749 (patch)
tree52d5be22195ff7f194e0a32d2b6b4061a6ad49f2 /contrib/packages/deb/ubuntu-trusty/debian
parent9d5522845767b64bc7d207adeafdee3f9e5e9799 (diff)
downloadtigervnc-376f2dda782bc59febc9af32336e7c6ebbf5c749.tar.gz
tigervnc-376f2dda782bc59febc9af32336e7c6ebbf5c749.zip
Clean up Ubuntu 14.04 FLTK build
The supporting scripts weren't really up to date, so remove them and just require the packager to include FLTK in the source tarball.
Diffstat (limited to 'contrib/packages/deb/ubuntu-trusty/debian')
-rwxr-xr-xcontrib/packages/deb/ubuntu-trusty/debian/get-orig-source.sh24
-rwxr-xr-xcontrib/packages/deb/ubuntu-trusty/debian/patch_fltk.sh52
-rwxr-xr-xcontrib/packages/deb/ubuntu-trusty/debian/rules28
3 files changed, 13 insertions, 91 deletions
diff --git a/contrib/packages/deb/ubuntu-trusty/debian/get-orig-source.sh b/contrib/packages/deb/ubuntu-trusty/debian/get-orig-source.sh
deleted file mode 100755
index d79a7242..00000000
--- a/contrib/packages/deb/ubuntu-trusty/debian/get-orig-source.sh
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/bash
-
-#curl -L -o tigervnc-1.3.0.tar.bz2 "http://downloads.sourceforge.net/project/tigervnc/tigervnc/1.3.0/tigervnc-1.3.0.tar.bz2"
-#tar xjf tigervnc-*.tar.bz2
-#rm tigervnc-*.tar.bz2
-curl -OL http://sourceforge.net/code-snapshots/svn/t/ti/tigervnc/code/tigervnc-code-5136-trunk.zip
-unzip tigervnc-code-*-trunk.zip
-mv tigervnc-code-*-trunk tigervnc-1.3.80
-rm tigervnc-code-*-trunk.zip
-pushd tigervnc-*
-curl -L -o fltk-1.3.2-source.tar.gz 'http://anonscm.debian.org/gitweb/?p=users/ucko/fltk1.3.git;a=snapshot;h=HEAD;sf=tgz'
-tar xzf fltk-*-source.tar.gz
-rm fltk-*-source.tar.gz
-mv fltk1.3-* fltk-1.3.2
-pushd fltk-*
-sh ../../debian/patch_fltk.sh
-find . -name "*.orig" -exec rm {} \;
-popd
-popd
-if [ -e tigervnc_1.3.80.orig.tar.gz ] ; then
- rm tigervnc_1.3.80.orig.tar.gz
-fi
-tar czf tigervnc_1.3.80.orig.tar.gz tigervnc-1.3.80
-rm -rf tigervnc-1.3.80
diff --git a/contrib/packages/deb/ubuntu-trusty/debian/patch_fltk.sh b/contrib/packages/deb/ubuntu-trusty/debian/patch_fltk.sh
deleted file mode 100755
index a2dc0f08..00000000
--- a/contrib/packages/deb/ubuntu-trusty/debian/patch_fltk.sh
+++ /dev/null
@@ -1,52 +0,0 @@
-#!/bin/bash
-set -e
-apply_patch()
-{
- rm -f $2
- curl -OL http://www.fltk.org/strfiles/$1/$2
- patch -p1 < $2
-}
-
-# Export dead key information from FLTK to the apps
-# http://www.fltk.org/str.php?L2599
-apply_patch 2599 fltk-1_v4.3.x-keyboard-x11.patch
-apply_patch 2599 fltk-1_v4.3.x-keyboard-win32.patch
-apply_patch 2599 fltk-1_v6.3.x-keyboard-osx.patch
-
-# Notify applications of changes to the clipboard
-# http://www.fltk.org/str.php?L2636
-apply_patch 2636 fltk-1.3.x-clipboard.patch
-apply_patch 2636 fltk-1_v6.3.x-clipboard-x11.patch
-apply_patch 2636 fltk-1_v3.3.x-clipboard-win32-fix.patch
-apply_patch 2636 fltk-1_v2.3.x-clipboard-win32.patch
-apply_patch 2636 fltk-1_v2.3.x-clipboard-osx.patch
-
-# Ability to convert a Fl_Pixmap to a Fl_RGB_Image
-# http://www.fltk.org/str.php?L2659
-apply_patch 2659 pixmap_v2.patch
-
-# Support for custom cursors
-# http://www.fltk.org/str.php?L2660
-apply_patch 2660 fltk-1_v5.3.x-cursor.patch
-
-# Improve modality interaction with WM
-# http://www.fltk.org/str.php?L2802
-apply_patch 2802 fltk-1_v2.3.0-modal.patch
-
-# Window icons
-# http://www.fltk.org/str.php?L2816
-apply_patch 2816 fltk-1_v3.3.0-icons.patch
-
-# Multihead
-# http://fltk.org/str.php?L2860
-apply_patch 2860 fltk-1.3.x-screen_num.patch
-apply_patch 2860 fltk-1_v3.3.x-multihead.patch
-
-# Apply DRC's patches to FLTK
-curl -L 'https://sourceforge.net/mailarchive/attachment.php?list_name=tigervnc-devel&message_id=512DD1FE.7090609%40users.sourceforge.net&counter=1' -o 0001-Add-BUILD_STATIC-feature-from-TigerVNC-to-optionally.patch
-curl -L 'https://sourceforge.net/mailarchive/attachment.php?list_name=tigervnc-devel&message_id=512DD1FE.7090609%40users.sourceforge.net&counter=2' -o 0002-Fl_cocoa.mm-depends-on-some-Carbon-functions-so-we-n.patch
-curl -L 'https://sourceforge.net/mailarchive/attachment.php?list_name=tigervnc-devel&message_id=512DD1FE.7090609%40users.sourceforge.net&counter=3' -o 0003-We-need-to-unset-CMAKE_REQUIRED_LIBRARIES-after-chec.patch
-
-patch -p1 -i 0001-Add-BUILD_STATIC-feature-from-TigerVNC-to-optionally.patch
-patch -p1 -i 0002-Fl_cocoa.mm-depends-on-some-Carbon-functions-so-we-n.patch
-patch -p1 -i 0003-We-need-to-unset-CMAKE_REQUIRED_LIBRARIES-after-chec.patch
diff --git a/contrib/packages/deb/ubuntu-trusty/debian/rules b/contrib/packages/deb/ubuntu-trusty/debian/rules
index 6c270a69..1ddd06ed 100755
--- a/contrib/packages/deb/ubuntu-trusty/debian/rules
+++ b/contrib/packages/deb/ubuntu-trusty/debian/rules
@@ -42,14 +42,6 @@ endif
export CC = gcc
-XCFLAGS = -Wall -Wunused -Wno-format-y2k -fPIE -fno-strict-aliasing
-
-get-orig-source: $(SOURCE_NAME)_$(SOURCE_VERSION).orig.tar.gz
- @
-
-$(SOURCE_NAME)_$(SOURCE_VERSION).orig.tar.gz:
- $(CURDIR)/get-orig-source.sh
-
# use xorg sources as shipped in xorg-server-source package
XORG_SOURCE_ARCHIVE = /usr/src/xorg-server.tar.xz
@@ -60,18 +52,24 @@ xorg-source-stamp: $(XORG_SOURCE_ARCHIVE)
patch -p1 < debian/xorg-source-patches/516_tigervnc-xorg-manpages.patch
touch xorg-source-stamp
+XCFLAGS = -Wall -Wunused -Wno-format-y2k -fPIE -fno-strict-aliasing
+
+fltk-stamp:
+ (cd fltk-*;DSOFLAGS="$(filter-out -fPIE -pie,$(LDFLAGS))" \
+ ./configure --enable-shared=no --enable-cairo --enable-cp936 \
+ --with-optim="$(CFLAGS) $(XCFLAGS)" --libdir=$(libdir))
+ make -C fltk-*
+ touch fltk-stamp
+
configure: config-stamp
-config-stamp: xorg-source-stamp
+config-stamp: xorg-source-stamp fltk-stamp
dh_testdir
# Add here commands to configure the package.
- (cd fltk-*;DSOFLAGS="$(filter-out -fPIE -pie,$(LDFLAGS))" \
- ./configure --enable-shared=no --enable-cairo --enable-cp936 \
- --with-optim="$(CFLAGS) $(XCFLAGS)" --libdir=$(libdir);make)
cmake -G"Unix Makefiles" \
-DBUILD_STATIC=off \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DFLTK_LIBRARIES="$(CURDIR)/fltk-1.3.4-1/lib/libfltk.a;$(CURDIR)/fltk-1.3.4-1/lib/libfltk_images.a;-lpng" \
- -DFLTK_INCLUDE_DIR=$(CURDIR)/fltk-1.3.4-1
+ -DFLTK_LIBRARIES="$(CURDIR)/fltk-1.3.4-2/lib/libfltk.a;$(CURDIR)/fltk-1.3.4-2/lib/libfltk_images.a;-lpng;-ldl" \
+ -DFLTK_INCLUDE_DIR=$(CURDIR)/fltk-1.3.4-2
(cd unix/xserver; \
export PIXMANINCDIR=/usr/include/pixman-1; \
autoreconf -fiv; \
@@ -291,4 +289,4 @@ binary-arch: build install
dh_builddeb -a
binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install get-orig-source
+.PHONY: build clean binary-indep binary-arch binary install