aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/packages/deb
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2017-12-22 10:35:29 +0100
committerPierre Ossman <ossman@cendio.se>2020-03-12 10:51:24 +0100
commitdf25ae41194eb85a48ccfabd7cb7d2c338ff4300 (patch)
tree253d0e068786bdb7d46df0213a3c9404c08c3a98 /contrib/packages/deb
parentebaa948e4685adce59e84242458fafb6f900bf0a (diff)
downloadtigervnc-df25ae41194eb85a48ccfabd7cb7d2c338ff4300.tar.gz
tigervnc-df25ae41194eb85a48ccfabd7cb7d2c338ff4300.zip
Always install systemd services
It is the most common init system these days so it should not be hidden in the contrib/ directory. This also removes all old SysV files from the contrib packages.
Diffstat (limited to 'contrib/packages/deb')
-rw-r--r--contrib/packages/deb/ubuntu-bionic/debian/local/vncserver.service94
-rw-r--r--contrib/packages/deb/ubuntu-bionic/debian/local/vncserver.sysconfig19
-rw-r--r--contrib/packages/deb/ubuntu-bionic/debian/rules8
-rw-r--r--contrib/packages/deb/ubuntu-xenial/debian/local/vncserver.service94
-rw-r--r--contrib/packages/deb/ubuntu-xenial/debian/local/vncserver.sysconfig19
-rw-r--r--contrib/packages/deb/ubuntu-xenial/debian/rules8
6 files changed, 4 insertions, 238 deletions
diff --git a/contrib/packages/deb/ubuntu-bionic/debian/local/vncserver.service b/contrib/packages/deb/ubuntu-bionic/debian/local/vncserver.service
deleted file mode 100644
index 86a8a910..00000000
--- a/contrib/packages/deb/ubuntu-bionic/debian/local/vncserver.service
+++ /dev/null
@@ -1,94 +0,0 @@
-#!/bin/bash
-#
-# Init file for TigerVNC Server
-#
-# chkconfig: - 91 35
-# description: TigerVNC remote X administration daemon.
-#
-# processname: Xvnc
-
-### BEGIN INIT INFO
-# Provides: vncservers
-# Required-Start: networking
-# Required-Stop: networking
-# Default-Start:
-# Default-Stop: 0 1 2 3 4 5 6
-# Short-Description: Starts and stops vncserver
-# Description: Used to provide remote X administration services.
-### END INIT INFO
-
-# Source function library.
-. /lib/lsb/init-functions
-
-### Default variables
-SYSCONFIG="/etc/default/vncservers"
-VNCSERVERS=""
-
-### Read configuration
-[ -r "$SYSCONFIG" ] && . "$SYSCONFIG"
-
-RETVAL=0
-prog=$"VNC server"
-
-start() {
- echo -n $"Starting $prog: "
- ulimit -S -c 0 >/dev/null 2>&1
- for display in ${VNCSERVERS}; do
- echo -n "${display} "
- if [ -r $(eval echo ~${display##*:})/.vnc/passwd ]; then
- unset BASH_ENV ENV
- log_begin_msg "Starting VNC Server for user ${display##*:}:"
- su ${display##*:} -c "cd ~${display##*:} && [ -f .vnc/passwd ] && vncserver :${display%%:*} ${VNCSERVERARGS[${display%:*}]}"
- RETVAL="$?"
- if [ "$RETVAL" -ne 0 ]; then
- log_end_msg 1
- break
- else
- log_end_msg 0
- fi
- else
- log_begin_msg "Not starting VNC Server for user ${display##*:}.\n File \"~${display##*:}/.vnc/passwd\" not found.\n Create a password file for the VNC server with vncpasswd"
- log_end_msg 1
- fi
- done
- echo
- [ "$RETVAL" -eq 0 ] && touch "/var/lock/vncserver"
- return $RETVAL
-}
-
-stop() {
- echo -n $"Shutting down $desc: "
- for display in ${VNCSERVERS}; do
- echo -n "${display} "
- unset BASH_ENV ENV
- log_begin_msg "Shutting down VNC Server for user ${display##*:}: "
- su ${display##*:} -c "vncserver -kill :${display%%:*}" >/dev/null 2>&1
- RETVAL="$?"
- [ "$RETVAL" -eq 0 ] && log_end_msg 0 || log_end_msg 1
- done
- echo
- [ "$RETVAL" -eq 0 ] && rm -f "/var/lock/vncserver"
- return $RETVAL
-}
-
-restart() {
- stop
- start
-}
-
-case "$1" in
- start)
- start
- ;;
- stop)
- stop
- ;;
- restart|reload)
- restart
- ;;
- *)
- echo $"Usage: $0 {start|stop|restart}"
- RETVAL=1
-esac
-
-exit $RETVAL
diff --git a/contrib/packages/deb/ubuntu-bionic/debian/local/vncserver.sysconfig b/contrib/packages/deb/ubuntu-bionic/debian/local/vncserver.sysconfig
deleted file mode 100644
index d18d0f14..00000000
--- a/contrib/packages/deb/ubuntu-bionic/debian/local/vncserver.sysconfig
+++ /dev/null
@@ -1,19 +0,0 @@
-# The VNCSERVERS variable is a list of display:user pairs.
-#
-# Uncomment the lines below to start a VNC server on display :2
-# as my 'myusername' (adjust this to your own). You will also
-# need to set a VNC password; run 'man vncpasswd' to see how
-# to do that.
-#
-# DO NOT RUN THIS SERVICE if your local area network is
-# untrusted! For a secure way of using VNC, see this URL:
-# http://kbase.redhat.com/faq/docs/DOC-7028
-
-# Use "-nolisten tcp" to prevent X connections to your VNC server via TCP.
-
-# Use "-localhost" to prevent remote VNC clients connecting except when
-# doing so through a secure tunnel. See the "-via" option in the
-# `man vncviewer' manual page.
-
-# VNCSERVERS="2:myusername"
-# VNCSERVERARGS[2]="-geometry 800x600 -nolisten tcp -localhost"
diff --git a/contrib/packages/deb/ubuntu-bionic/debian/rules b/contrib/packages/deb/ubuntu-bionic/debian/rules
index e60413d3..ff6ff18e 100644
--- a/contrib/packages/deb/ubuntu-bionic/debian/rules
+++ b/contrib/packages/deb/ubuntu-bionic/debian/rules
@@ -57,7 +57,8 @@ config-stamp: xorg-source-stamp
cmake -G"Unix Makefiles" \
-DBUILD_STATIC=off \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DSYSCONF_DIR:PATH=/etc
+ -DSYSCONF_DIR:PATH=/etc \
+ -DUNIT_DIR:PATH=/lib/systemd/system
(cd unix/xserver; \
export PIXMANINCDIR=/usr/include/pixman-1; \
autoreconf -fiv; \
@@ -187,11 +188,6 @@ install: build
$(CURDIR)/debian/tigervncserver/usr/share/man/man1/Xtigervnc.1
# delete development files
rm -f $(CURDIR)/debian/tigervncserver/usr/lib/xorg/modules/extensions/libvnc.la
- # install server service
- install -o root -g root -m 755 -D $(CURDIR)/debian/local/vncserver.service \
- $(CURDIR)/debian/tigervncserver/etc/init.d/vncserver
- install -o root -g root -m 644 -D $(CURDIR)/debian/local/vncserver.sysconfig \
- $(CURDIR)/debian/tigervncserver/etc/default/vncservers
# move viewer files to viewer package, rename on the fly
mkdir -p $(CURDIR)/debian/xtigervncviewer/usr/bin
mv $(CURDIR)/debian/tigervncserver/usr/bin/vncviewer \
diff --git a/contrib/packages/deb/ubuntu-xenial/debian/local/vncserver.service b/contrib/packages/deb/ubuntu-xenial/debian/local/vncserver.service
deleted file mode 100644
index 86a8a910..00000000
--- a/contrib/packages/deb/ubuntu-xenial/debian/local/vncserver.service
+++ /dev/null
@@ -1,94 +0,0 @@
-#!/bin/bash
-#
-# Init file for TigerVNC Server
-#
-# chkconfig: - 91 35
-# description: TigerVNC remote X administration daemon.
-#
-# processname: Xvnc
-
-### BEGIN INIT INFO
-# Provides: vncservers
-# Required-Start: networking
-# Required-Stop: networking
-# Default-Start:
-# Default-Stop: 0 1 2 3 4 5 6
-# Short-Description: Starts and stops vncserver
-# Description: Used to provide remote X administration services.
-### END INIT INFO
-
-# Source function library.
-. /lib/lsb/init-functions
-
-### Default variables
-SYSCONFIG="/etc/default/vncservers"
-VNCSERVERS=""
-
-### Read configuration
-[ -r "$SYSCONFIG" ] && . "$SYSCONFIG"
-
-RETVAL=0
-prog=$"VNC server"
-
-start() {
- echo -n $"Starting $prog: "
- ulimit -S -c 0 >/dev/null 2>&1
- for display in ${VNCSERVERS}; do
- echo -n "${display} "
- if [ -r $(eval echo ~${display##*:})/.vnc/passwd ]; then
- unset BASH_ENV ENV
- log_begin_msg "Starting VNC Server for user ${display##*:}:"
- su ${display##*:} -c "cd ~${display##*:} && [ -f .vnc/passwd ] && vncserver :${display%%:*} ${VNCSERVERARGS[${display%:*}]}"
- RETVAL="$?"
- if [ "$RETVAL" -ne 0 ]; then
- log_end_msg 1
- break
- else
- log_end_msg 0
- fi
- else
- log_begin_msg "Not starting VNC Server for user ${display##*:}.\n File \"~${display##*:}/.vnc/passwd\" not found.\n Create a password file for the VNC server with vncpasswd"
- log_end_msg 1
- fi
- done
- echo
- [ "$RETVAL" -eq 0 ] && touch "/var/lock/vncserver"
- return $RETVAL
-}
-
-stop() {
- echo -n $"Shutting down $desc: "
- for display in ${VNCSERVERS}; do
- echo -n "${display} "
- unset BASH_ENV ENV
- log_begin_msg "Shutting down VNC Server for user ${display##*:}: "
- su ${display##*:} -c "vncserver -kill :${display%%:*}" >/dev/null 2>&1
- RETVAL="$?"
- [ "$RETVAL" -eq 0 ] && log_end_msg 0 || log_end_msg 1
- done
- echo
- [ "$RETVAL" -eq 0 ] && rm -f "/var/lock/vncserver"
- return $RETVAL
-}
-
-restart() {
- stop
- start
-}
-
-case "$1" in
- start)
- start
- ;;
- stop)
- stop
- ;;
- restart|reload)
- restart
- ;;
- *)
- echo $"Usage: $0 {start|stop|restart}"
- RETVAL=1
-esac
-
-exit $RETVAL
diff --git a/contrib/packages/deb/ubuntu-xenial/debian/local/vncserver.sysconfig b/contrib/packages/deb/ubuntu-xenial/debian/local/vncserver.sysconfig
deleted file mode 100644
index d18d0f14..00000000
--- a/contrib/packages/deb/ubuntu-xenial/debian/local/vncserver.sysconfig
+++ /dev/null
@@ -1,19 +0,0 @@
-# The VNCSERVERS variable is a list of display:user pairs.
-#
-# Uncomment the lines below to start a VNC server on display :2
-# as my 'myusername' (adjust this to your own). You will also
-# need to set a VNC password; run 'man vncpasswd' to see how
-# to do that.
-#
-# DO NOT RUN THIS SERVICE if your local area network is
-# untrusted! For a secure way of using VNC, see this URL:
-# http://kbase.redhat.com/faq/docs/DOC-7028
-
-# Use "-nolisten tcp" to prevent X connections to your VNC server via TCP.
-
-# Use "-localhost" to prevent remote VNC clients connecting except when
-# doing so through a secure tunnel. See the "-via" option in the
-# `man vncviewer' manual page.
-
-# VNCSERVERS="2:myusername"
-# VNCSERVERARGS[2]="-geometry 800x600 -nolisten tcp -localhost"
diff --git a/contrib/packages/deb/ubuntu-xenial/debian/rules b/contrib/packages/deb/ubuntu-xenial/debian/rules
index 7fbde337..35bc2d08 100644
--- a/contrib/packages/deb/ubuntu-xenial/debian/rules
+++ b/contrib/packages/deb/ubuntu-xenial/debian/rules
@@ -58,7 +58,8 @@ config-stamp: xorg-source-stamp
cmake -G"Unix Makefiles" \
-DBUILD_STATIC=off \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DSYSCONF_DIR:PATH=/etc
+ -DSYSCONF_DIR:PATH=/etc \
+ -DUNIT_DIR:PATH=/lib/systemd/system
(cd unix/xserver; \
export PIXMANINCDIR=/usr/include/pixman-1; \
autoreconf -fiv; \
@@ -188,11 +189,6 @@ install: build
$(CURDIR)/debian/tigervncserver/usr/share/man/man1/Xtigervnc.1
# delete development files
rm -f $(CURDIR)/debian/tigervncserver/usr/lib/xorg/modules/extensions/libvnc.la
- # install server service
- install -o root -g root -m 755 -D $(CURDIR)/debian/local/vncserver.service \
- $(CURDIR)/debian/tigervncserver/etc/init.d/vncserver
- install -o root -g root -m 644 -D $(CURDIR)/debian/local/vncserver.sysconfig \
- $(CURDIR)/debian/tigervncserver/etc/default/vncservers
# move viewer files to viewer package, rename on the fly
mkdir -p $(CURDIR)/debian/xtigervncviewer/usr/bin
mv $(CURDIR)/debian/tigervncserver/usr/bin/vncviewer \