aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/packages/rpm
diff options
context:
space:
mode:
authorMark Mielke <mark.mielke@gmail.com>2018-12-15 10:00:32 -0500
committerPierre Ossman <ossman@cendio.se>2020-05-31 11:28:14 +0200
commit0a2108b6767fd18d39e5ddaae073a3c2892232ae (patch)
tree56643fcd0854e001a09452892790f0c62dc4c5ce /contrib/packages/rpm
parentf9adce49228b047c2df7c5c0fd02871fbde654a9 (diff)
downloadtigervnc-0a2108b6767fd18d39e5ddaae073a3c2892232ae.tar.gz
tigervnc-0a2108b6767fd18d39e5ddaae073a3c2892232ae.zip
Automatically pick the correct X.org patch
Update RPM package build process to automatically detect and apply the correct X.org patch.
Diffstat (limited to 'contrib/packages/rpm')
-rw-r--r--contrib/packages/rpm/el7/SPECS/tigervnc.spec8
1 files changed, 6 insertions, 2 deletions
diff --git a/contrib/packages/rpm/el7/SPECS/tigervnc.spec b/contrib/packages/rpm/el7/SPECS/tigervnc.spec
index 46081ce0..21d5bb5f 100644
--- a/contrib/packages/rpm/el7/SPECS/tigervnc.spec
+++ b/contrib/packages/rpm/el7/SPECS/tigervnc.spec
@@ -1,6 +1,6 @@
Name: tigervnc
Version: @VERSION@
-Release: 4%{?snap:.%{snap}}%{?dist}
+Release: 5%{?snap:.%{snap}}%{?dist}
Summary: A TigerVNC remote display system
Group: User Interface/Desktops
@@ -137,7 +137,8 @@ pushd unix/xserver
for all in `find . -type f -perm -001`; do
chmod -x "$all"
done
-patch -p1 -b --suffix .vnc < ../xserver120.patch
+xserver_patch="../xserver$(rpm -q --qf '%{VERSION}' xorg-x11-server-source | awk -F. '{ print $1 $2 }').patch"
+patch -p1 -b --suffix .vnc < "$xserver_patch"
popd
%build
@@ -296,6 +297,9 @@ fi
%{_datadir}/selinux/packages/vncsession.pp
%changelog
+* Mon Feb 11 2019 Mark Mielke <mmielke@ciena.com> 1.9.80-5
+- Automatically detect and apply the correct X.org patch.
+
* Mon Jan 14 2019 Pierre Ossman <ossman@cendio.se> 1.9.80-4
- Use system FLTK for build
- Add libXrandr-devel as a dependency so x0vncserver gets resize support.