aboutsummaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2014-12-03 13:58:54 +0100
committerPierre Ossman <ossman@cendio.se>2014-12-03 13:58:54 +0100
commit0b142f55554e2191c00edb87286ba64cd9411f9e (patch)
tree5d7ce0b1583945ab9aaeeb6ab94c876023e4ea3d /po/CMakeLists.txt
parent7cc06403d4ee728995db5e373d157ae7b8338b38 (diff)
downloadtigervnc-0b142f55554e2191c00edb87286ba64cd9411f9e.tar.gz
tigervnc-0b142f55554e2191c00edb87286ba64cd9411f9e.zip
Sort translation strings by file instead
This variant keeps more context for the translators by having related strings clumped together.
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index f574510d..b4c69792 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -25,7 +25,7 @@ if (GETTEXT_XGETTEXT_EXECUTABLE)
--keyword=N_
"--copyright-holder=TigerVNC Team and many others \(see README.txt\)"
--msgid-bugs-address=tigervnc-devel@googlegroups.com
- --sort-output
+ --sort-by-file
--add-location
${po_source}
COMMENT "Updating tigervnc.pot"
@@ -40,7 +40,7 @@ foreach(lang ${po_FILES})
# Update po files after pot file
add_custom_command(TARGET translations_update POST_BUILD
COMMAND ${GETTEXT_MSGMERGE_EXECUTABLE} --quiet --update --backup=none
- --sort-output ${po} ${CMAKE_CURRENT_SOURCE_DIR}/tigervnc.pot
+ --sort-by-file ${po} ${CMAKE_CURRENT_SOURCE_DIR}/tigervnc.pot
COMMENT "Updating ${lang}.po"
)