aboutsummaryrefslogtreecommitdiffstats
path: root/vncviewer/CMakeLists.txt
diff options
context:
space:
mode:
authorDRC <dcommander@users.sourceforge.net>2011-10-05 09:32:28 +0000
committerDRC <dcommander@users.sourceforge.net>2011-10-05 09:32:28 +0000
commit58fdda4ff0555152a7aab62f3a4378d49ea747f8 (patch)
tree7859b44b371379f680662ce59f36923f2c82de39 /vncviewer/CMakeLists.txt
parentf50ec7c5504f708fafd7ee711f6524b327d3c783 (diff)
downloadtigervnc-58fdda4ff0555152a7aab62f3a4378d49ea747f8.tar.gz
tigervnc-58fdda4ff0555152a7aab62f3a4378d49ea747f8.zip
It is our convention to install Windows executables in the top-level install directory rather than under bin/
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4705 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'vncviewer/CMakeLists.txt')
-rw-r--r--vncviewer/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/vncviewer/CMakeLists.txt b/vncviewer/CMakeLists.txt
index 03fb9c04..5639ccb1 100644
--- a/vncviewer/CMakeLists.txt
+++ b/vncviewer/CMakeLists.txt
@@ -49,7 +49,11 @@ if(NOT GNUTLS_FOUND AND WIN32)
target_link_libraries(vncviewer ws2_32)
endif()
-install(TARGETS vncviewer DESTINATION bin)
+if(WIN32)
+ install(TARGETS vncviewer DESTINATION .)
+else()
+ install(TARGETS vncviewer DESTINATION bin)
+endif()
if(UNIX)
install(FILES vncviewer.man DESTINATION man/man1 RENAME vncviewer.1)
endif()