aboutsummaryrefslogtreecommitdiffstats
path: root/vncviewer/CMakeLists.txt
diff options
context:
space:
mode:
authorAaron Sowry <aaron@cendio.se>2019-05-24 12:00:47 +1200
committerNiko Lehto <nikle@cendio.se>2020-05-29 15:26:33 +0200
commit95ad018961f384f6e43c80c4f5473064a6f3aedd (patch)
tree67343e830dafe9eb1060da7f65c0183ca6fbd9ac /vncviewer/CMakeLists.txt
parentd71135b02bd47037e5c210dbf678815a880065ed (diff)
downloadtigervnc-95ad018961f384f6e43c80c4f5473064a6f3aedd.tar.gz
tigervnc-95ad018961f384f6e43c80c4f5473064a6f3aedd.zip
Implement touch gesture handling on Unix
Allows the user to perform certain important mouse operations using touch gestures instead.
Diffstat (limited to 'vncviewer/CMakeLists.txt')
-rw-r--r--vncviewer/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/vncviewer/CMakeLists.txt b/vncviewer/CMakeLists.txt
index 92b516cb..74e2deef 100644
--- a/vncviewer/CMakeLists.txt
+++ b/vncviewer/CMakeLists.txt
@@ -4,6 +4,7 @@ include_directories(${GETTEXT_INCLUDE_DIR})
include_directories(${CMAKE_SOURCE_DIR}/common)
set(VNCVIEWER_SOURCES
menukey.cxx
+ BaseTouchHandler.cxx
CConn.cxx
DesktopWindow.cxx
EmulateMB.cxx
@@ -33,7 +34,7 @@ if(WIN32)
elseif(APPLE)
set(VNCVIEWER_SOURCES ${VNCVIEWER_SOURCES} cocoa.mm osx_to_qnum.c)
else()
- set(VNCVIEWER_SOURCES ${VNCVIEWER_SOURCES} XInputTouchHandler.cxx xkb_to_qnum.c)
+ set(VNCVIEWER_SOURCES ${VNCVIEWER_SOURCES} GestureHandler.cxx XInputTouchHandler.cxx xkb_to_qnum.c)
endif()
if(WIN32)