aboutsummaryrefslogtreecommitdiffstats
path: root/vncviewer/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2011-04-28 14:38:04 +0000
committerPierre Ossman <ossman@cendio.se>2011-04-28 14:38:04 +0000
commitb232b5fd73140c09f739ddbbd045a89fc7259f19 (patch)
treeab6b2388cce07d06ff5e8b5a3c4f03c6e2c7cf8c /vncviewer/CMakeLists.txt
parentbb445ef944f3850de98a6a90b44b1f87c341e989 (diff)
downloadtigervnc-b232b5fd73140c09f739ddbbd045a89fc7259f19.tar.gz
tigervnc-b232b5fd73140c09f739ddbbd045a89fc7259f19.zip
Finish up the gettext handling in CMake. The included functions in CMake only
take care of finding the gettext tools, not the headers and libraries needed to build things. Use the licq project as inspiration on how to solve this. git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4389 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'vncviewer/CMakeLists.txt')
-rw-r--r--vncviewer/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/vncviewer/CMakeLists.txt b/vncviewer/CMakeLists.txt
index b4f888e1..c832b354 100644
--- a/vncviewer/CMakeLists.txt
+++ b/vncviewer/CMakeLists.txt
@@ -1,4 +1,5 @@
include_directories(${FLTK_INCLUDE_DIR})
+include_directories(${GETTEXT_INCLUDE_DIR})
include_directories(${CMAKE_SOURCE_DIR}/common)
set(VNCVIEWER_SOURCES
@@ -16,6 +17,6 @@ endif()
add_executable(vncviewer ${VNCVIEWER_SOURCES})
-target_link_libraries(vncviewer rfb network rdr os Xregion ${FLTK_LIBRARIES})
+target_link_libraries(vncviewer rfb network rdr os Xregion ${FLTK_LIBRARIES} ${GETTEXT_LIBRARIES})
install (TARGETS vncviewer DESTINATION bin)