aboutsummaryrefslogtreecommitdiffstats
path: root/win/vncviewer/Makefile.am
diff options
context:
space:
mode:
authorPeter Åstrand <astrand@cendio.se>2008-12-09 10:27:33 +0000
committerPeter Åstrand <astrand@cendio.se>2008-12-09 10:27:33 +0000
commiteaff3bc8fa335b322981173fb3a8bfa158d88227 (patch)
tree044a77f27839ef61ef9ec92853ddae31f7014c86 /win/vncviewer/Makefile.am
parent00e0dbfdcbad585795300ee9c7d8cabab5eb487c (diff)
downloadtigervnc-eaff3bc8fa335b322981173fb3a8bfa158d88227.tar.gz
tigervnc-eaff3bc8fa335b322981173fb3a8bfa158d88227.zip
Basic support for building Windows vncviewer using MinGW. This patch
includes non-intrusive changes, more tweaks will follow. Details: * Defining WINVER and _WIN32_IE in both common and win modules. * Need to build CFTMsgWriter and CFTMsgReader. * Added configure script and Makefiles. git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@3326 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'win/vncviewer/Makefile.am')
-rw-r--r--win/vncviewer/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/win/vncviewer/Makefile.am b/win/vncviewer/Makefile.am
new file mode 100644
index 00000000..ff6a6d69
--- /dev/null
+++ b/win/vncviewer/Makefile.am
@@ -0,0 +1,50 @@
+bin_PROGRAMS = vncviewer
+
+HDRS = \
+ CConn.h \
+ CConnOptions.h \
+ CConnThread.h \
+ ConnectingDialog.h \
+ ConnectionDialog.h \
+ DesktopWindow.h \
+ FileTransfer.h \
+ FTBrowseDlg.h \
+ FTDialog.h \
+ FTListView.h \
+ FTProgress.h \
+ InfoDialog.h \
+ ListenServer.h \
+ ListenTrayIcon.h \
+ MRU.h \
+ OptionsDialog.h \
+ resource.h \
+ UserPasswdDialog.h \
+ ViewerToolBar.h
+
+vncviewer_SOURCES = $(HDRS) \
+ buildTime.cxx \
+ CConn.cxx \
+ CConnOptions.cxx \
+ CConnThread.cxx \
+ ConnectingDialog.cxx \
+ ConnectionDialog.cxx \
+ DesktopWindow.cxx \
+ FileTransfer.cxx \
+ FTBrowseDlg.cxx \
+ FTDialog.cxx \
+ FTListView.cxx \
+ FTProgress.cxx \
+ InfoDialog.cxx \
+ OptionsDialog.cxx \
+ UserPasswdDialog.cxx \
+ ViewerToolBar.cxx \
+ vncviewer.cxx
+
+vncviewer_CPPFLAGS = -I$(COMMON_DIR) -I$(top_srcdir)
+
+vncviewer_LDADD = $(COMMON_DIR)/rfb/librfb.la $(top_srcdir)/rfb_win32/librfb_win32.la $(COMMON_DIR)/Xregion/libXregion.la \
+ $(COMMON_DIR)/network/libnetwork.la $(COMMON_DIR)/rdr/librdr.la -lws2_32 -lgdi32 -luser32 -lcomctl32 -lversion -lcomdlg32
+
+vncviewer_LDFLAGS = -I$(top_srcdir)/win
+
+