aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b57b5e61..3d566f1e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -337,9 +337,9 @@ if(UNIX AND NOT APPLE)
endif()
# check for password pwquality check support
-option(ENABLE_PWQUALITY "Enable password pwquality check" ON)
-if(ENABLE_PWQUALITY)
- if(UNIX)
+if(UNIX AND NOT APPLE)
+ option(ENABLE_PWQUALITY "Enable password pwquality check" ON)
+ if(ENABLE_PWQUALITY)
find_package(PkgConfig)
if(PKG_CONFIG_FOUND)
pkg_check_modules(PWQUALITY pwquality)