aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb0a778a..eb4014a1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -255,13 +255,11 @@ set(HAVE_PAM ${ENABLE_PAM})
# Check for socket functions
if(WIN32)
# check_function_exists() cannot handle stdcall, so just define things
- set(HAVE_INET_ATON 1)
set(HAVE_GETADDRINFO 1)
else()
if(${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
set(CMAKE_REQUIRED_LIBRARIES socket)
endif()
- check_function_exists(inet_aton HAVE_INET_ATON)
check_function_exists(getaddrinfo HAVE_GETADDRINFO)
set(CMAKE_REQUIRED_LIBRARIES)
endif()