aboutsummaryrefslogtreecommitdiffstats
path: root/common/jpeg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/jpeg/Makefile.am')
-rw-r--r--common/jpeg/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/common/jpeg/Makefile.am b/common/jpeg/Makefile.am
index 26fe44c5..bafa3d49 100644
--- a/common/jpeg/Makefile.am
+++ b/common/jpeg/Makefile.am
@@ -1,4 +1,13 @@
+if WITH_SHARED
+
+lib_LTLIBRARIES = libjpeg.la
+
+else
+
noinst_LTLIBRARIES = libjpeg.la
+
+endif
+
noinst_HEADERS = jconfig.h jerror.h jmorecfg.h jpeglib.h
HDRS = jchuff.h jdct.h jdhuff.h jerror.h jinclude.h jmemsys.h jmorecfg.h \