aboutsummaryrefslogtreecommitdiffstats
path: root/common/rfb/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'common/rfb/CMakeLists.txt')
-rw-r--r--common/rfb/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/common/rfb/CMakeLists.txt b/common/rfb/CMakeLists.txt
index fc5a37bf..84e0be62 100644
--- a/common/rfb/CMakeLists.txt
+++ b/common/rfb/CMakeLists.txt
@@ -64,6 +64,13 @@ set(RFB_SOURCES
encodings.cxx
util.cxx)
+if(ENABLE_H264 AND NOT H264_LIBS STREQUAL "NONE")
+ set(RFB_SOURCES ${RFB_SOURCES} H264Decoder.cxx H264DecoderContext.cxx)
+ if(H264_LIBS STREQUAL "LIBAV")
+ set(RFB_SOURCES ${RFB_SOURCES} H264LibavDecoderContext.cxx)
+ endif()
+endif()
+
if(UNIX)
set(RFB_SOURCES ${RFB_SOURCES} Logger_syslog.cxx)
endif()