aboutsummaryrefslogtreecommitdiffstats
path: root/common/rfb/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'common/rfb/CMakeLists.txt')
-rw-r--r--common/rfb/CMakeLists.txt70
1 files changed, 70 insertions, 0 deletions
diff --git a/common/rfb/CMakeLists.txt b/common/rfb/CMakeLists.txt
new file mode 100644
index 00000000..6bfb5fef
--- /dev/null
+++ b/common/rfb/CMakeLists.txt
@@ -0,0 +1,70 @@
+include_directories(${CMAKE_SOURCE_DIR}/common ${CMAKE_SOURCE_DIR}/win
+ ${CMAKE_SOURCE_DIR}/common/jpeg ${CMAKE_SOURCE_DIR}/common/jpeg/win)
+
+add_library(rfb STATIC
+ Blacklist.cxx
+ CConnection.cxx
+ CMsgHandler.cxx
+ CMsgReader.cxx
+ CMsgReaderV3.cxx
+ CMsgWriter.cxx
+ CMsgWriterV3.cxx
+ CSecurityPlain.cxx
+ CSecurityStack.cxx
+ CSecurityVeNCrypt.cxx
+ CSecurityVncAuth.cxx
+ CapsContainer.cxx
+ CapsList.cxx
+ ComparingUpdateTracker.cxx
+ Configuration.cxx
+ ConnParams.cxx
+ Cursor.cxx
+ Decoder.cxx
+ d3des.c
+ Encoder.cxx
+ HTTPServer.cxx
+ HextileDecoder.cxx
+ HextileEncoder.cxx
+ KeyRemapper.cxx
+ LogWriter.cxx
+ Logger.cxx
+ Logger_file.cxx
+ Logger_stdio.cxx
+ Password.cxx
+ PixelBuffer.cxx
+ PixelFormat.cxx
+ RREEncoder.cxx
+ RREDecoder.cxx
+ RawDecoder.cxx
+ RawEncoder.cxx
+ Region.cxx
+ SConnection.cxx
+ SMsgHandler.cxx
+ SMsgReader.cxx
+ SMsgReaderV3.cxx
+ SMsgWriter.cxx
+ SMsgWriterV3.cxx
+ ServerCore.cxx
+ Security.cxx
+ SecurityServer.cxx
+ SecurityClient.cxx
+ SSecurityPlain.cxx
+ SSecurityStack.cxx
+ SSecurityVncAuth.cxx
+ SSecurityVeNCrypt.cxx
+ ScaledPixelBuffer.cxx
+ ScaleFilters.cxx
+ Timer.cxx
+ TightDecoder.cxx
+ TightEncoder.cxx
+ TightPalette.cxx
+ TransImageGetter.cxx
+ UpdateTracker.cxx
+ VNCSConnectionST.cxx
+ VNCServerST.cxx
+ ZRLEEncoder.cxx
+ ZRLEDecoder.cxx
+ encodings.cxx
+ util.cxx)
+
+target_link_libraries(rfb jpeg os)