aboutsummaryrefslogtreecommitdiffstats
path: root/unix/vncpasswd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unix/vncpasswd/CMakeLists.txt')
-rw-r--r--unix/vncpasswd/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/unix/vncpasswd/CMakeLists.txt b/unix/vncpasswd/CMakeLists.txt
index 9b672041..f490a933 100644
--- a/unix/vncpasswd/CMakeLists.txt
+++ b/unix/vncpasswd/CMakeLists.txt
@@ -4,5 +4,9 @@ add_executable(vncpasswd
target_include_directories(vncpasswd PUBLIC ${CMAKE_SOURCE_DIR}/common)
target_link_libraries(vncpasswd tx rfb os)
+if(PWQUALITY_FOUND)
+ target_link_libraries(vncpasswd pwquality)
+endif()
+
install(TARGETS vncpasswd DESTINATION ${CMAKE_INSTALL_FULL_BINDIR})
install(FILES vncpasswd.man DESTINATION ${CMAKE_INSTALL_FULL_MANDIR}/man1 RENAME vncpasswd.1)