aboutsummaryrefslogtreecommitdiffstats
path: root/unix/xserver/hw/vnc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'unix/xserver/hw/vnc/Makefile.am')
-rw-r--r--unix/xserver/hw/vnc/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/unix/xserver/hw/vnc/Makefile.am b/unix/xserver/hw/vnc/Makefile.am
index f9ed19d9..f9372183 100644
--- a/unix/xserver/hw/vnc/Makefile.am
+++ b/unix/xserver/hw/vnc/Makefile.am
@@ -42,6 +42,8 @@ Xvnc_SOURCES = xvnc.c \
# recommendation for coaxing automake.
nodist_EXTRA_Xvnc_SOURCES = dummy.cxx
+Xvnc_CPPFLAGS = $(AM_CPPFLAGS)
+
LOCAL_LIBS = \
$(XVNC_LIBS) \
$(XSERVER_LIBS) \
@@ -53,6 +55,14 @@ Xvnc_LDADD = $(LOCAL_LIBS) $(XSERVER_SYS_LIBS) $(XVNC_SYS_LIBS)
Xvnc_LDFLAGS = $(LD_EXPORT_SYMBOLS_FLAG)
+if DRI3
+Xvnc_SOURCES += vncDRI3.h vncDRI3.c vncDRI3Draw.c
+Xvnc_CPPFLAGS += \
+ -I$(top_srcdir)/dri3 \
+ $(GBM_CFLAGS)
+Xvnc_LDADD += $(GBM_LIBS)
+endif
+
libvnc_la_LTLIBRARIES = libvnc.la
libvnc_ladir = $(moduledir)/extensions