aboutsummaryrefslogtreecommitdiffstats
path: root/win/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'win/CMakeLists.txt')
-rw-r--r--win/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/win/CMakeLists.txt b/win/CMakeLists.txt
index 951f16ad..6f0886d9 100644
--- a/win/CMakeLists.txt
+++ b/win/CMakeLists.txt
@@ -1,3 +1,7 @@
+if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
+ message(FATAL_ERROR "cmake must be invoked with the top level directory")
+endif()
+
include_directories(${CMAKE_SOURCE_DIR}/common ${CMAKE_SOURCE_DIR}/win)
configure_file(resdefs.h.in ${CMAKE_CURRENT_BINARY_DIR}/resdefs.h)