aboutsummaryrefslogtreecommitdiffstats
path: root/win/vncconfig/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'win/vncconfig/CMakeLists.txt')
-rw-r--r--win/vncconfig/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/win/vncconfig/CMakeLists.txt b/win/vncconfig/CMakeLists.txt
new file mode 100644
index 00000000..9883dbd8
--- /dev/null
+++ b/win/vncconfig/CMakeLists.txt
@@ -0,0 +1,18 @@
+include_directories(${CMAKE_BINARY_DIR}/win)
+
+# Disable auto-generated manifests, since we have our own
+if(MSVC)
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /MANIFEST:NO")
+endif()
+
+add_executable(vncconfig WIN32
+ Legacy.cxx
+ PasswordDialog.cxx
+ vncconfig.cxx
+ vncconfig.rc)
+
+target_link_libraries(vncconfig rfb_win32 rfb Xregion network rdr ws2_32.lib)
+
+install(TARGETS vncconfig
+ RUNTIME DESTINATION .
+)