aboutsummaryrefslogtreecommitdiffstats
path: root/win/vncviewer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'win/vncviewer/CMakeLists.txt')
-rw-r--r--win/vncviewer/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/win/vncviewer/CMakeLists.txt b/win/vncviewer/CMakeLists.txt
new file mode 100644
index 00000000..863e2d07
--- /dev/null
+++ b/win/vncviewer/CMakeLists.txt
@@ -0,0 +1,28 @@
+include_directories(${CMAKE_BINARY_DIR}/win)
+
+# Disable auto-generated manifests, since we have our own
+if(MSVC)
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /MANIFEST:NO")
+endif()
+
+add_executable(vncviewer WIN32
+ buildTime.cxx
+ CConn.cxx
+ CConnOptions.cxx
+ CConnThread.cxx
+ ConnectingDialog.cxx
+ ConnectionDialog.cxx
+ DesktopWindow.cxx
+ InfoDialog.cxx
+ OptionsDialog.cxx
+ UserPasswdDialog.cxx
+ ViewerToolBar.cxx
+ vncviewer.cxx
+ vncviewer.rc)
+
+target_link_libraries(vncviewer rfb rfb_win32 Xregion network rdr
+ ws2_32.lib)
+
+install(TARGETS vncviewer
+ RUNTIME DESTINATION .
+)