aboutsummaryrefslogtreecommitdiffstats
path: root/common/core
Commit message (Collapse)AuthorAgeFilesLines
* Also split help output lines on commaPierre Ossman2025-03-131-6/+17
| | | | | | | This is needed when we have very long defaults for list parameters. Note that the logic gets a bit more convoluted as we want to keep the comma with the word, unlike the whitespace.
* Wrap description and default value the samePierre Ossman2025-03-131-9/+5
|
* Handle all whitespace when wrapping help outputPierre Ossman2025-03-131-5/+3
|
* Handle whitespace in list parametersPierre Ossman2025-03-131-0/+7
|
* Add enumeration list parameterPierre Ossman2025-03-132-1/+155
| | | | Same as IntListParameter and StringListParamter, but for enumerations.
* Convert Log parameter to StringListParameterPierre Ossman2025-03-132-9/+11
|
* Add string list parameter typePierre Ossman2025-03-122-0/+59
| | | | | Same as for IntListParameter, consolidate the list handling code to a single place.
* Add integer list parameter typePierre Ossman2025-03-122-2/+194
| | | | Consolidate handling of a list of values in a single piece of code.
* Add enumeration parameter typePierre Ossman2025-03-122-0/+96
| | | | | Consolidate validation of enumeration in a central place since this is now a popular type of paramater.
* Validate integer parameter valuesPierre Ossman2025-03-061-3/+16
| | | | | Complain so that the user/developer sees the issue rather than just silently ignoring the problem.
* Avoid std::string(nullptr) for StringParameterPierre Ossman2025-03-061-1/+1
| | | | This is undefined and crashes on macOS.
* Move concurrency abstration layer to corePierre Ossman2025-02-255-1/+458
| | | | | OS abstractions are generic enough that we can merge these with the new core library.
* Move winerrno.h to corePierre Ossman2025-02-251-0/+91
| | | | | OS abstractions are generic enough that we can merge these with the new core library.
* Move application directory handling to corePierre Ossman2025-02-253-1/+238
| | | | | These are general plumbing, so they fit in nicely with the new core library.
* Rename core/util to core/stringPierre Ossman2025-02-256-9/+9
| | | | | It's just string helper functions here, so let's get rid of the catch-all name for this module.
* Get rid of __rfbmax()/__rfbmin()Pierre Ossman2025-02-252-31/+9
| | | | | | | | They weren't that well used, and were mostly just confusing special functions anyway. Allows us to move away from generic and ambigious headers such as "util".
* Keep all time helpers in a single placePierre Ossman2025-02-253-32/+34
|
* Handle bad ordering to time helpersPierre Ossman2025-02-251-0/+3
| | | | | | These functions assumes there is a specific ordering between the given moments. Make sure we don't return something completely crazy if this ordering isn't true.
* Move time utilities to separate filePierre Ossman2025-02-256-56/+120
| | | | Let's clear things up by categorizing our utility functions.
* Move timers to core libraryPierre Ossman2025-02-253-0/+316
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move logging to core libraryPierre Ossman2025-02-2513-9/+785
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move configuration to core libraryPierre Ossman2025-02-253-1/+678
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move base exception classes to core libraryPierre Ossman2025-02-253-0/+214
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move utility functions to core libraryPierre Ossman2025-02-133-1/+795
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move basic data types to core libraryPierre Ossman2025-02-134-0/+433
Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.