aboutsummaryrefslogtreecommitdiffstats
path: root/tests
Commit message (Collapse)AuthorAgeFilesLines
* Don't force everyone to implement setCursorPos()Pierre Ossman7 days2-10/+0
| | | | | You need to activate the feature by setting supportsCursorPosition, so there is no point in forcing everyone to implement the handler.
* Properly store cursor in ServerParams objectPierre Ossman7 days2-10/+0
| | | | | | We already had a field in the ServerParams structure, but we never actually stored anything in it. Let's fix that so the cursor behaves like other state we get from the server.
* Make CMsgHandler/SMsgHandler pure interfacesPierre Ossman8 days1-0/+12
| | | | | | It's a bit confusing that some handling is done in CMsgHandler/SMsgHandler, and some handling is done in CConnection/SConnection.
* Mark internal connection callbacks as protectedPierre Ossman8 days1-1/+1
| | | | | | These are just for interactions internally within the connection objects and their sub classes. Mark them as protected to make the API more clear, and to avoid accidental use.
* Handle whitespace in list parametersPierre Ossman2025-03-131-0/+24
|
* Add enumeration list parameterPierre Ossman2025-03-131-0/+108
| | | | Same as IntListParameter and StringListParamter, but for enumerations.
* Add string list parameter typePierre Ossman2025-03-121-0/+64
| | | | | Same as for IntListParameter, consolidate the list handling code to a single place.
* Add integer list parameter typePierre Ossman2025-03-121-0/+130
| | | | Consolidate handling of a list of values in a single piece of code.
* Add enumeration parameter typePierre Ossman2025-03-121-0/+102
| | | | | Consolidate validation of enumeration in a central place since this is now a popular type of paramater.
* Validate integer parameter valuesPierre Ossman2025-03-061-0/+18
| | | | | Complain so that the user/developer sees the issue rather than just silently ignoring the problem.
* Add unit tests for parameter typesPierre Ossman2025-03-062-0/+369
|
* Convert unicode unit tests to Google TestPierre Ossman2025-02-272-142/+133
|
* Convert pixelformat unit tests to Google TestPierre Ossman2025-02-272-111/+171
|
* Convert gesturehandler unit tests to Google TestPierre Ossman2025-02-272-513/+312
|
* Convert conv unit tests to Google TestPierre Ossman2025-02-272-102/+88
|
* Convert configargs unit tests to Google TestPierre Ossman2025-02-272-115/+78
|
* Convert hostport unit tests to Google TestPierre Ossman2025-02-272-63/+97
|
* Convert EmulateMB unit tests to Google TestPierre Ossman2025-02-272-229/+145
|
* Convert convertLF() unit tests to Google TestPierre Ossman2025-02-272-93/+45
|
* Enable Google Test unit test frameworkPierre Ossman2025-02-272-1/+10
| | | | Let's try to use something more proper for our unit tests.
* Rename core/util to core/stringPierre Ossman2025-02-253-3/+3
| | | | | It's just string helper functions here, so let's get rid of the catch-all name for this module.
* Move time utilities to separate filePierre Ossman2025-02-251-0/+1
| | | | Let's clear things up by categorizing our utility functions.
* Move timers to core libraryPierre Ossman2025-02-253-25/+25
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move configuration to core libraryPierre Ossman2025-02-254-84/+86
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move base exception classes to core libraryPierre Ossman2025-02-253-4/+0
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move utility functions to core libraryPierre Ossman2025-02-135-23/+24
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move basic data types to core libraryPierre Ossman2025-02-135-18/+18
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Use initializer lists for basic data typesPierre Ossman2025-02-132-33/+33
| | | | | | | | Try to keep the code more compact for the simple things where the type should be obvious from the context. Helps us avoid line wrapping. Also remove explicit conversions to Region where the compiler is able to figure it out by itself, again to reduce line length.
* Move getHostAndPort() to network libraryPierre Ossman2025-02-132-3/+3
| | | | | This is a network function, so it makes more sense in the network library.
* Reduce header #include:sPierre Ossman2025-02-131-3/+1
| | | | | Make compile times faster by reducing the number of headers included in other headers.
* Fix handling of empty -parameter= argumentsPierre Ossman2025-02-061-0/+37
| | | | Broken in e97e225.
* Fix handling of bool on/off argumentsPierre Ossman2025-01-101-6/+6
| | | | | These two values were overlooked in the look-ahead list and hence did not work reliably.
* Consolidate argument parsing in single functionPierre Ossman2025-01-103-9/+336
| | | | | Avoid duplicating this complexity everywhere and make sure all commands get the same handling and fixes.
* Merge branch 'master' of https://github.com/madnicendio/tigervncPierre Ossman2024-11-221-2/+2
|\
| * Standardize log message prefix formatMadeleine Nilsson2024-11-111-2/+2
| | | | | | | | The reason for this is to keep a consistency through out the project.
* | Merge branch 'mouse-button-support' of https://github.com/CendioHalim/tigervncPierre Ossman2024-11-181-3/+3
|\ \
| * | vncviewer: support for back/forward mouse buttonsAdam Halim2024-10-221-3/+3
| |/ | | | | | | | | | | | | | | This commit implements the pseudo-encoding ExtendedMouseButtons which makes it possible to use the back/forward mouse buttons. This commit contains work originally done by PixelSmith <manny33@frontbuffer.com>.
* | Use standard library naming for exceptionsPierre Ossman2024-11-062-2/+2
| | | | | | | | | | This makes things more consistent since we mix with the standard library exceptions so often.
* | Use standard exception classesPierre Ossman2024-11-063-5/+6
| | | | | | | | | | Use the more specific already included exception classes for common errors to keep things more understandable.
* | Subclass exceptions from std::exceptionPierre Ossman2024-11-062-3/+3
| | | | | | | | | | Make sure our exceptions are part of the standard exception class hierarchy.
* | Use what() to access exception descriptionPierre Ossman2024-11-062-4/+4
|/ | | | Harmonize with the standard C++ exceptions.
* Move getUserPasswd()/showMsgBox() to CConnectionKang Lin2024-08-302-0/+23
| | | | | Problems with the original code: A process can only establish one connection. After modification, multiple connections can be supported.
* Remove unused setPixelFormat() callbackPierre Ossman2024-08-122-8/+1
| | | | | This was made obsolete in dd45b44 when we extended the serverInit() callback.
* Better type for pointer button maskPierre Ossman2024-08-121-3/+3
| | | | | This is a very limited bit field, so use an 8 bit type to clearly show how many bits are available.
* Avoid shadowing variablesPierre Ossman2024-06-242-5/+5
| | | | | It's a source of confusion and possibly bugs to reuse the same variable name for multiple things.
* Mark overridden virtual functionsPierre Ossman2024-06-245-36/+36
| | | | | Use the new "override" keyword to properly differentiate between new virtual methods, and existing virtual methods being overridden.
* Use nullptr in all C++ codePierre Ossman2024-06-245-22/+22
| | | | | It's more readable than 0, and a bit safer than NULL, so let's try to follow modern norms.
* Merge branch 'casantos-rhbz_2180903' of https://github.com/casantos/tigervncPierre Ossman2024-05-201-2/+5
|\
| * vncconfig: add option to force view-only remote client connectionsCarlos Santos2024-04-261-0/+3
| | | | | | | | | | | | | | | | Specifies that the server must ignore all keyboard or mouse events sent by the client. Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=2180903 Signed-off-by: Carlos Santos <casantos@redhat.com>
| * Move the AccessRights type and constants to the rfb namespaceCarlos Santos2024-04-231-2/+2
| | | | | | | | | | | | | | | | | | They must belong to the rfb namespace, not to the SConnection class. Also add an AccessNone constant, since it's better to use a mnemonic symbol rather than zero to initialize the accessRights members. Signed-off-by: Carlos Santos <casantos@redhat.com>