aboutsummaryrefslogtreecommitdiffstats
path: root/unix/x0vncserver
Commit message (Collapse)AuthorAgeFilesLines
* Make use of IntParameter range validationPierre Ossman2025-03-062-5/+7
|
* Fix bad forward declarations of StringParameterPierre Ossman2025-03-031-1/+1
| | | | This should have been done as part of cf1bc66.
* Stop relying on "using namespace"Pierre Ossman2025-02-254-41/+32
| | | | | | There were not many uses of this left after the move to std::exception and the move to the core library. Let's get rid of the last stragglers and reduce the risk of name collisions.
* Rename core/util to core/stringPierre Ossman2025-02-251-1/+1
| | | | | It's just string helper functions here, so let's get rid of the catch-all name for this module.
* Move timers to core libraryPierre Ossman2025-02-251-3/+3
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move logging to core libraryPierre Ossman2025-02-256-18/+18
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move configuration to core libraryPierre Ossman2025-02-256-39/+60
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move base exception classes to core libraryPierre Ossman2025-02-251-1/+1
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move utility functions to core libraryPierre Ossman2025-02-131-5/+8
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move basic data types to core libraryPierre Ossman2025-02-138-21/+27
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Use initializer lists for basic data typesPierre Ossman2025-02-131-6/+6
| | | | | | | | Try to keep the code more compact for the simple things where the type should be obvious from the context. Helps us avoid line wrapping. Also remove explicit conversions to Region where the compiler is able to figure it out by itself, again to reduce line length.
* Reduce header #include:sPierre Ossman2025-02-135-2/+11
| | | | | Make compile times faster by reducing the number of headers included in other headers.
* Fix argument parsing regression in x0vncserverPierre Ossman2025-01-231-1/+1
| | | | | The argument index progression wasn't properly adjusted in e97e225, causing it to skip arguments.
* Fix some option dashes in man pages.Joachim Falk2025-01-121-1/+1
| | | | Some '-' in man pages, which start options, are rendered as Unicode dashes, not ASCII '-'; fix this.
*-. Merge branches 'argparse', 'nothread' and 'config' of ↵Pierre Ossman2025-01-102-177/+188
|\ \ | | | | | | | | | https://github.com/CendioOssman/tigervnc
| | * Describe multiple -Log entries in man pagesPierre Ossman2025-01-071-1/+1
| | | | | | | | | | | | | | | It's possible to configure multiple loggers with different settings. This was properly described in the --help output, but not the man pages.
| | * Sort parameters in -help and man pagesPierre Ossman2025-01-071-160/+160
| | | | | | | | | | | | Makes it much easier to find all the different options.
| | * Prefer "PasswordFile" over "rfbauth"Pierre Ossman2025-01-071-1/+1
| | | | | | | | | | | | | | | The latter is the legacy alias, so prefer the former in the documentation.
| | * Remove server and viewer config typesPierre Ossman2025-01-071-2/+0
| |/ |/| | | | | | | | | | | We don't consistently use these, so they are just confusing. Instead, we rely on the linker to not include unnecessary objects, and hence irrelevant configuration objects.
| * Give better error message on bad argumentsPierre Ossman2025-01-101-1/+12
| | | | | | | | | | Instead of just printing the huge usage text and hoping the user figures out what was wrong.
| * Make all user commands handle --help and --versionPierre Ossman2025-01-101-0/+6
| |
| * Consolidate argument parsing in single functionPierre Ossman2025-01-101-15/+11
|/ | | | | Avoid duplicating this complexity everywhere and make sure all commands get the same handling and fixes.
* Capitalize even more logging and exceptionsPierre Ossman2024-11-221-3/+3
|
* Merge branch 'master' of https://github.com/madnicendio/tigervncPierre Ossman2024-11-224-7/+7
|\
| * Capitalize first letter in log, exception & errorMadeleine Nilsson2024-11-211-2/+2
| | | | | | | | The reason for this is to keep a consistency through out the project.
| * Standardize on sentence case in titlesMadeleine (ThinLinc team)2024-11-113-5/+5
| | | | | | | | The reason for this is to keep a consistency through out the project.
* | Merge branch 'mouse-button-support' of https://github.com/CendioHalim/tigervncPierre Ossman2024-11-182-6/+6
|\ \
| * | Add server support for forward/back mouse buttonsAdam Halim2024-10-222-6/+6
| | | | | | | | | | | | | | | | | | | | | | | | | | | This commit adds support for the pseudo-encoding ExtendedMouseButtons in Xvnc and x0vncserver, which makes it possible to use to use the back/forward mouse buttons. This commit contains work originally done by PixelSmith <manny33@frontbuffer.com>.
* | | Merge branch 'stdexcept' of github.com:CendioOssman/tigervncPierre Ossman2024-11-072-7/+6
|\ \ \ | |_|/ |/| |
| * | Use standard library naming for exceptionsPierre Ossman2024-11-061-1/+1
| | | | | | | | | | | | | | | This makes things more consistent since we mix with the standard library exceptions so often.
| * | Use standard exception classesPierre Ossman2024-11-061-2/+1
| | | | | | | | | | | | | | | Use the more specific already included exception classes for common errors to keep things more understandable.
| * | Subclass exceptions from std::exceptionPierre Ossman2024-11-062-2/+2
| | | | | | | | | | | | | | | Make sure our exceptions are part of the standard exception class hierarchy.
| * | Use what() to access exception descriptionPierre Ossman2024-11-062-2/+2
| | | | | | | | | | | | Harmonize with the standard C++ exceptions.
| * | Use static string for exceptionsPierre Ossman2024-11-061-1/+1
| | | | | | | | | | | | | | | In preparation for using the built in C++ exception classes, which do not accept a format string.
* | | Do proper top level window setup for selection windowPierre Ossman2024-10-221-1/+1
|/ /
* | Merge branch 'errno' of github.com:CendioOssman/tigervncPierre Ossman2024-10-091-1/+1
|\ \
| * | Consistently use SocketException for socket errorsPierre Ossman2024-10-091-1/+1
| |/ | | | | | | | | | | The behaviour is not consistent as Windows doesn't use errno for socket errors, but Unix systems do. Always use the same exception to keep things somewhat sane.
* / Add clipboard support to x0vncserverGaurav Ujjwal2024-09-257-8/+334
|/
* Better type for pointer button maskPierre Ossman2024-08-122-3/+3
| | | | | This is a very limited bit field, so use an 8 bit type to clearly show how many bits are available.
* Remove InputHandler interfacePierre Ossman2024-08-122-4/+0
| | | | | The different uses of this interface are not that closely related and there is no need for them to have a common interface class.
* Improve x0vncserver key allocation log linePierre Ossman2024-08-061-1/+2
| | | | | Follow the standard XK_ prefix, and also include the hex value for easier debugging.
* Merge branch 'fix-unknown-keysym' of https://github.com/gujjwal00/tigervncPierre Ossman2024-08-062-16/+60
|\
| * Improve unknown keysym handlingGaurav Ujjwal2024-06-302-16/+60
| | | | | | | | | | | | Instead of giving up after all free keycodes have been used, Keycodes from previously added keysyms will be reused. Re: #93
* | Fix x0vncserver handling of timersPierre Ossman2024-07-051-3/+3
|/ | | | Bug fix for bf28683.
* Avoid redundant argumentsPierre Ossman2024-06-242-14/+14
| | | | | Remove redundant arguments where the method already has access to the relevant variable as an object attribute.
* Simplify code using range-based for loopsPierre Ossman2024-06-241-18/+9
| | | | | | | | | These are often more readable as they avoid a lot of the boilerplate of iterating over fixed arrays or STL containers. Note that this change is very conservative to avoid noise in "git blame". Only loops where this is a clear improvement have been converted.
* Prefer std::find() over manual searchPierre Ossman2024-06-241-6/+6
| | | | | Let's avoid reimplementing something basic that's available in the standard library. It also makes the code easier to read.
* Mark overridden virtual functionsPierre Ossman2024-06-244-21/+21
| | | | | Use the new "override" keyword to properly differentiate between new virtual methods, and existing virtual methods being overridden.
* Use nullptr in all C++ codePierre Ossman2024-06-246-53/+54
| | | | | It's more readable than 0, and a bit safer than NULL, so let's try to follow modern norms.
* Merge branch 'present' of github.com:CendioOssman/tigervncPierre Ossman2024-06-193-7/+13
|\