aboutsummaryrefslogtreecommitdiffstats
path: root/win/winvnc
Commit message (Collapse)AuthorAgeFilesLines
* Make use of IntParameter range validationPierre Ossman2025-03-062-2/+3
|
* Move concurrency abstration layer to corePierre Ossman2025-02-255-31/+25
| | | | | OS abstractions are generic enough that we can merge these with the new core library.
* Rename core/util to core/stringPierre Ossman2025-02-252-2/+2
| | | | | It's just string helper functions here, so let's get rid of the catch-all name for this module.
* Move logging to core libraryPierre Ossman2025-02-256-11/+13
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move configuration to core libraryPierre Ossman2025-02-252-4/+6
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move base exception classes to core libraryPierre Ossman2025-02-253-5/+5
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move utility functions to core libraryPierre Ossman2025-02-135-2/+14
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move getHostAndPort() to network libraryPierre Ossman2025-02-131-1/+2
| | | | | This is a network function, so it makes more sense in the network library.
* Reduce header #include:sPierre Ossman2025-02-131-0/+1
| | | | | Make compile times faster by reducing the number of headers included in other headers.
* Update visible copyright year to 2025Pierre Ossman2025-01-141-1/+1
|
* Always use lowercase "t" for TigerVNC teamPierre Ossman2025-01-141-1/+1
| | | | It's not a formal name, so use regular case.
*-. Merge branches 'argparse', 'nothread' and 'config' of ↵Pierre Ossman2025-01-101-10/+6
|\ \ | | | | | | | | | https://github.com/CendioOssman/tigervnc
| | * Remove server and viewer config typesPierre Ossman2025-01-071-2/+0
| |/ |/| | | | | | | | | | | We don't consistently use these, so they are just confusing. Instead, we rely on the linker to not include unnecessary objects, and hence irrelevant configuration objects.
| * Consolidate argument parsing in single functionPierre Ossman2025-01-101-8/+6
|/ | | | | Avoid duplicating this complexity everywhere and make sure all commands get the same handling and fixes.
* Merge branch 'master' of https://github.com/madnicendio/tigervncPierre Ossman2024-11-227-32/+32
|\
| * Capitalize first letter in log, exception & errorMadeleine Nilsson2024-11-213-6/+6
| | | | | | | | The reason for this is to keep a consistency through out the project.
| * Standardize on sentence case in titlesMadeleine (ThinLinc team)2024-11-116-26/+26
| | | | | | | | The reason for this is to keep a consistency through out the project.
* | Use standard library naming for exceptionsPierre Ossman2024-11-063-5/+5
| | | | | | | | | | This makes things more consistent since we mix with the standard library exceptions so often.
* | Use standard exception classesPierre Ossman2024-11-062-3/+3
| | | | | | | | | | Use the more specific already included exception classes for common errors to keep things more understandable.
* | Subclass exceptions from std::exceptionPierre Ossman2024-11-064-5/+5
| | | | | | | | | | Make sure our exceptions are part of the standard exception class hierarchy.
* | Use what() to access exception descriptionPierre Ossman2024-11-064-6/+6
|/ | | | Harmonize with the standard C++ exceptions.
* Split SystemException to handle WindowsPierre Ossman2024-10-093-5/+5
| | | | | | | | | | | | | Windows has (at least) two error namespaces, both errno and GetLastResult(). These overlap, so it is important we keep track of which one we are dealing with. To make things extra problematic, the BSD socket API normally uses errno, but on Windows it has been mapped in to the GetLastResult() namespace. Try to keep better control of this by using separate classes for the namespaces.
* Remove fake framebuffer update request callPierre Ossman2024-08-121-1/+0
| | | | | | | | | This method should only be called when the client actually sends a framebuffer update request, otherwise we might send data the client is not ready for. It's unclear what the purpose of this call is, so we have no better fix than to just remove it.
* Avoid shadowing variablesPierre Ossman2024-06-241-2/+1
| | | | | It's a source of confusion and possibly bugs to reuse the same variable name for multiple things.
* Mark overridden virtual functionsPierre Ossman2024-06-247-16/+16
| | | | | Use the new "override" keyword to properly differentiate between new virtual methods, and existing virtual methods being overridden.
* Use nullptr in all C++ codePierre Ossman2024-06-2410-50/+50
| | | | | It's more readable than 0, and a bit safer than NULL, so let's try to follow modern norms.
* Remove the network::SocketServer interface.Carlos Santos2024-04-262-4/+4
| | | | | | | Move these RFB specific things to rfb::VNCServer, for clarity. Signed-off-by: Pierre Ossman <ossman@cendio.se> Signed-off-by: Carlos Santos <casantos@redhat.com>
* Move the AccessRights type and constants to the rfb namespaceCarlos Santos2024-04-231-15/+15
| | | | | | | | | They must belong to the rfb namespace, not to the SConnection class. Also add an AccessNone constant, since it's better to use a mnemonic symbol rather than zero to initialize the accessRights members. Signed-off-by: Carlos Santos <casantos@redhat.com>
* Update copyright year to 2024Samuel Mannehed2024-01-091-1/+1
|
* Update copyright year to 2023Samuel Mannehed2023-07-201-1/+1
|
* Prefer target_include_directories()Pierre Ossman2023-03-311-2/+2
| | | | | It is more specific, and it properly sets up propagation when include directories also need to be used further down a dependency chain.
* Remove unused rfb/util.h includesPierre Ossman2023-02-042-0/+2
| | | | | | | | These files don't use anything from this header, so remove the include. This exposes some missing includes in other places, though. So add an explicit include in the files that were relying on an indirect inclusion.
* Remove "str" prefix from string helpersPierre Ossman2023-02-042-4/+4
| | | | | This matches the naming in STL, which is what we are mostly mimicing now that we are using std::string for these functions.
* Use std::string for string memory managementPierre Ossman2023-02-041-6/+5
| | | | | Avoids a bit of complexity by delegating that handling to a string object.
* Use std::string instead of CharArrayPierre Ossman2023-02-048-43/+39
| | | | | Let's use a more common type instead of something homegrown. Should be more familiar to new developers.
* Return std::string instead of dynamic allocationsPierre Ossman2023-02-041-10/+9
| | | | | | We mostly use classical C strings, but the memory management around them can get confusing and error prone. Let's use std::string for the cases where we need to return a newly allocated string.
* Return static char buffer from some methodsPierre Ossman2023-02-041-1/+1
| | | | | | | | | This mimics how some system functions (like inet_ntop()) work, and avoids complexity around ownership of the returned string buffer. The downside is that the string must be consumed directly as it will be overwritten on the next call, but that is not an issue with the current usage.
* Use string literal instead of dynamic bufferPierre Ossman2023-02-042-8/+8
| | | | | These don't need to be changed, so let's just keep it simple with a constant string literal.
* Use StringParameters directlyPierre Ossman2023-02-041-2/+1
| | | | | We don't need to make extra copies of the string in most cases, so let's simplify the code and access the string directly when we can.
* Get rid of TCHAR magicPierre Ossman2023-02-0410-52/+48
| | | | | We never use Windows' "UNICODE" mode anyway, so let's get rid of this complexity.
* Work around -Wcast-function-typePierre Ossman2023-01-051-1/+1
| | | | | That warning doesn't play well with Windows' GetProcAddress(), so add some extra casting to work around it.
* Explicitly mark switch case fall throughPierre Ossman2023-01-051-0/+1
| | | | | This allows us to separate accidental fall through from explicit ones, which allows us to turn on such checks in the compiler.
* Explicitly mark unused parametersPierre Ossman2023-01-043-4/+4
| | | | | This allows us to separate accidentally unused, from explicitly unused parameters, which allows us to turn on such checks in the compiler.
* Don't do access checks on early clientsPierre Ossman2022-11-071-3/+5
| | | | | They don't get access bits until they've been authenticated, so avoid doing any checks on clients in those early states.
* Remove 32-/64-bit distinctionsPierre Ossman2022-01-211-7/+2
| | | | | The migration from 32-bit to 64-bit has long passed. Let's get rid of all distinctions as native applications it the norm now.
* Update copyright year to 2022Pierre Ossman2022-01-051-1/+1
|
* Be consistent in including config.hPierre Ossman2021-12-307-0/+29
| | | | | | The generally recommended way is to include it from source files, not headers. We had a mix of both. Let's try to be consistent and follow the recommended way.
* Update copyright year to 2021Pierre Ossman2021-01-251-1/+1
|
* Use standard install dir variable namesPierre Ossman2020-03-121-1/+1
| | | | | This makes our builds directly compatible with most distributions without packagers/users having to specify extra flags.
* Update copyright year to 2020Pierre Ossman2020-01-161-1/+1
|