aboutsummaryrefslogtreecommitdiffstats
path: root/common/network/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2018-05-29 16:46:19 +0200
committerPierre Ossman <ossman@cendio.se>2018-05-29 16:50:55 +0200
commitfe2e5fca2135acec490dc7284cfbca86ebe2610b (patch)
tree44b890e6ce88f735c47740a4640b34ce687066ad /common/network/CMakeLists.txt
parentcb99be55d818a73be7dea51a2de4c5c16d0439a9 (diff)
parent39594b801dc041d40b1348bf2efcf6f64215cd60 (diff)
downloadtigervnc-fe2e5fca2135acec490dc7284cfbca86ebe2610b.tar.gz
tigervnc-fe2e5fca2135acec490dc7284cfbca86ebe2610b.zip
Merge branch 'unix' of https://github.com/CendioOssman/tigervnc
Diffstat (limited to 'common/network/CMakeLists.txt')
-rw-r--r--common/network/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/common/network/CMakeLists.txt b/common/network/CMakeLists.txt
index b624c8e6..d00ca452 100644
--- a/common/network/CMakeLists.txt
+++ b/common/network/CMakeLists.txt
@@ -1,8 +1,15 @@
include_directories(${CMAKE_SOURCE_DIR}/common)
-add_library(network STATIC
+set(NETWORK_SOURCES
+ Socket.cxx
TcpSocket.cxx)
+if(NOT WIN32)
+ set(NETWORK_SOURCES ${NETWORK_SOURCES} UnixSocket.cxx)
+endif()
+
+add_library(network STATIC ${NETWORK_SOURCES})
+
if(WIN32)
target_link_libraries(network ws2_32)
endif()