aboutsummaryrefslogtreecommitdiffstats
path: root/common/network/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'common/network/CMakeLists.txt')
-rw-r--r--common/network/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/common/network/CMakeLists.txt b/common/network/CMakeLists.txt
index b624c8e6..d00ca452 100644
--- a/common/network/CMakeLists.txt
+++ b/common/network/CMakeLists.txt
@@ -1,8 +1,15 @@
include_directories(${CMAKE_SOURCE_DIR}/common)
-add_library(network STATIC
+set(NETWORK_SOURCES
+ Socket.cxx
TcpSocket.cxx)
+if(NOT WIN32)
+ set(NETWORK_SOURCES ${NETWORK_SOURCES} UnixSocket.cxx)
+endif()
+
+add_library(network STATIC ${NETWORK_SOURCES})
+
if(WIN32)
target_link_libraries(network ws2_32)
endif()