aboutsummaryrefslogtreecommitdiffstats
path: root/common/os/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2023-03-30 21:00:12 +0200
committerPierre Ossman <ossman@cendio.se>2023-03-31 11:03:10 +0200
commit640c5503c1b74d518a34bbce0fb7392876e8fb6d (patch)
treef4c2cf9fb20e75914f4ea74d02c63e8c0bc9d4d6 /common/os/CMakeLists.txt
parent00dc3c0c8d14d2d281e9e273f78abe6d44ed537e (diff)
downloadtigervnc-640c5503c1b74d518a34bbce0fb7392876e8fb6d.tar.gz
tigervnc-640c5503c1b74d518a34bbce0fb7392876e8fb6d.zip
Prefer target_include_directories()
It is more specific, and it properly sets up propagation when include directories also need to be used further down a dependency chain.
Diffstat (limited to 'common/os/CMakeLists.txt')
-rw-r--r--common/os/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/common/os/CMakeLists.txt b/common/os/CMakeLists.txt
index deaf2f96..2573d088 100644
--- a/common/os/CMakeLists.txt
+++ b/common/os/CMakeLists.txt
@@ -1,10 +1,9 @@
-include_directories(${CMAKE_SOURCE_DIR}/common)
-
add_library(os STATIC
Mutex.cxx
Thread.cxx
os.cxx)
+target_include_directories(os PUBLIC ${CMAKE_SOURCE_DIR}/common)
target_link_libraries(os rdr)
if(UNIX)