aboutsummaryrefslogtreecommitdiffstats
path: root/tests/unit
Commit message (Collapse)AuthorAgeFilesLines
* Handle whitespace in list parametersPierre Ossman2025-03-131-0/+24
|
* Add enumeration list parameterPierre Ossman2025-03-131-0/+108
| | | | Same as IntListParameter and StringListParamter, but for enumerations.
* Add string list parameter typePierre Ossman2025-03-121-0/+64
| | | | | Same as for IntListParameter, consolidate the list handling code to a single place.
* Add integer list parameter typePierre Ossman2025-03-121-0/+130
| | | | Consolidate handling of a list of values in a single piece of code.
* Add enumeration parameter typePierre Ossman2025-03-121-0/+102
| | | | | Consolidate validation of enumeration in a central place since this is now a popular type of paramater.
* Validate integer parameter valuesPierre Ossman2025-03-061-0/+18
| | | | | Complain so that the user/developer sees the issue rather than just silently ignoring the problem.
* Add unit tests for parameter typesPierre Ossman2025-03-062-0/+369
|
* Convert unicode unit tests to Google TestPierre Ossman2025-02-272-142/+133
|
* Convert pixelformat unit tests to Google TestPierre Ossman2025-02-272-111/+171
|
* Convert gesturehandler unit tests to Google TestPierre Ossman2025-02-272-513/+312
|
* Convert conv unit tests to Google TestPierre Ossman2025-02-272-102/+88
|
* Convert configargs unit tests to Google TestPierre Ossman2025-02-272-115/+78
|
* Convert hostport unit tests to Google TestPierre Ossman2025-02-272-63/+97
|
* Convert EmulateMB unit tests to Google TestPierre Ossman2025-02-272-229/+145
|
* Convert convertLF() unit tests to Google TestPierre Ossman2025-02-272-93/+45
|
* Enable Google Test unit test frameworkPierre Ossman2025-02-271-0/+7
| | | | Let's try to use something more proper for our unit tests.
* Rename core/util to core/stringPierre Ossman2025-02-252-2/+2
| | | | | It's just string helper functions here, so let's get rid of the catch-all name for this module.
* Move timers to core libraryPierre Ossman2025-02-253-25/+25
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move configuration to core libraryPierre Ossman2025-02-252-72/+73
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move utility functions to core libraryPierre Ossman2025-02-133-19/+19
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Move basic data types to core libraryPierre Ossman2025-02-132-5/+5
| | | | | | | Make it clearer what is protocol handling and what is just general plumbing. This is one step of several.
* Use initializer lists for basic data typesPierre Ossman2025-02-131-32/+32
| | | | | | | | Try to keep the code more compact for the simple things where the type should be obvious from the context. Helps us avoid line wrapping. Also remove explicit conversions to Region where the compiler is able to figure it out by itself, again to reduce line length.
* Move getHostAndPort() to network libraryPierre Ossman2025-02-132-3/+3
| | | | | This is a network function, so it makes more sense in the network library.
* Fix handling of empty -parameter= argumentsPierre Ossman2025-02-061-0/+37
| | | | Broken in e97e225.
* Fix handling of bool on/off argumentsPierre Ossman2025-01-101-6/+6
| | | | | These two values were overlooked in the look-ahead list and hence did not work reliably.
* Consolidate argument parsing in single functionPierre Ossman2025-01-102-0/+329
| | | | | Avoid duplicating this complexity everywhere and make sure all commands get the same handling and fixes.
* Merge branch 'mouse-button-support' of https://github.com/CendioHalim/tigervncPierre Ossman2024-11-181-3/+3
|\
| * vncviewer: support for back/forward mouse buttonsAdam Halim2024-10-221-3/+3
| | | | | | | | | | | | | | | | This commit implements the pseudo-encoding ExtendedMouseButtons which makes it possible to use the back/forward mouse buttons. This commit contains work originally done by PixelSmith <manny33@frontbuffer.com>.
* | Use standard exception classesPierre Ossman2024-11-061-1/+2
| | | | | | | | | | Use the more specific already included exception classes for common errors to keep things more understandable.
* | Subclass exceptions from std::exceptionPierre Ossman2024-11-061-1/+1
|/ | | | | Make sure our exceptions are part of the standard exception class hierarchy.
* Better type for pointer button maskPierre Ossman2024-08-121-3/+3
| | | | | This is a very limited bit field, so use an 8 bit type to clearly show how many bits are available.
* Avoid shadowing variablesPierre Ossman2024-06-241-1/+1
| | | | | It's a source of confusion and possibly bugs to reuse the same variable name for multiple things.
* Mark overridden virtual functionsPierre Ossman2024-06-242-2/+2
| | | | | Use the new "override" keyword to properly differentiate between new virtual methods, and existing virtual methods being overridden.
* Use nullptr in all C++ codePierre Ossman2024-06-241-2/+2
| | | | | It's more readable than 0, and a bit safer than NULL, so let's try to follow modern norms.
* Merge branch 'types2' of https://github.com/CendioOssman/tigervncPierre Ossman2023-06-301-0/+54
|\
| * Don't allow surrugate code points in UTF-8Pierre Ossman2023-06-301-0/+5
| | | | | | | | | | | | These are not valid outside of UTF-16 so seeing them in a UTF-8 sequence means that something is wrong with that sequence. Best to filter them out rather than letting them propagate and have unknown effects.
| * Clean up string encoding handlingPierre Ossman2023-06-301-0/+49
| | | | | | | | | | | | We should handle this in the low-level protocol code as much as possible to avoid mistakes. This way the rest of the code can assume that strings are always UTF-8 with \n line endings.
* | Prefer target_include_directories()Pierre Ossman2023-03-311-1/+1
|/ | | | | It is more specific, and it properly sets up propagation when include directories also need to be used further down a dependency chain.
* Remove custom CharArray typePierre Ossman2023-02-041-0/+1
| | | | | It has now been replaced, mostly by std::string, so remove the actual type definition.
* Return std::string instead of dynamic allocationsPierre Ossman2023-02-043-25/+15
| | | | | | We mostly use classical C strings, but the memory management around them can get confusing and error prone. Let's use std::string for the cases where we need to return a newly allocated string.
* Use stdint typesPierre Ossman2023-02-011-13/+13
| | | | | Avoid having our own custom stuff and instead use the modern, standard types, for familiarity.
* Explicitly mark unused parametersPierre Ossman2023-01-047-7/+7
| | | | | This allows us to separate accidentally unused, from explicitly unused parameters, which allows us to turn on such checks in the compiler.
* Mark system include paths correctlyPierre Ossman2023-01-041-1/+1
| | | | | This makes sure the compiler doesn't complain about problems in those files.
* Ignore whitespace around components of host-and-port specificationCatherine Tower2022-09-011-0/+12
| | | | This is to make the code more tolerant of typos when entering a hostname
* Move include_directories() to proper placesPierre Ossman2022-08-251-1/+2
| | | | We should scope these as narrowely as possible to avoid side effects.
* Be consistent in including config.hPierre Ossman2021-12-307-0/+28
| | | | | | The generally recommended way is to include it from source files, not headers. We had a mix of both. Let's try to be consistent and follow the recommended way.
* Correctly handle invalid UTF-16 code pointsPierre Ossman2020-10-051-0/+2
| | | | | Some code points are reserved for the UTF-16 coding itself and must not appear as input data to the algorithm.
* Fix conversion of latin-1 to UTF-8Pierre Ossman2020-10-051-0/+34
| | | | Signed bug prevented anything not ASCII from being coded correctly.
* Fix UTF-16 encoding/decoding of high code pointsPierre Ossman2020-10-051-0/+4
| | | | | Everything outside of BMP was handled incorrectly and was coded as completely different code points.
* Return the correct number of consumed UTF-8 bytesPierre Ossman2020-10-052-0/+168
| | | | | | | | This would mess up most conversions from UTF-8 as the caller wouldn't know how far to step to get to the next valid character, resulting in markers for invalid data to be injected here and there. Also add some unit tests to avoid this reoccurring.